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1.0 Overview 
 

This typical example illustrates the steps necessary for using InRoads in the design of a new 

highway construction project. It walks through the complete project design cycle from creating 

the project file structure to final design output. The project presented in this example is for 

demonstration only. The work flow reflects the specific type of highway project. The example 

doesn’t reflect the whole range of InRoads capabilities and the methods used in the example may 

require modification for a specific project.  

 

For easy identification, the directory, folder and file names are in italics in this document. 

 

Project Type: 

New construction of a rural, two lane, undivided highway with earth, rock and swamp 

treatments.  

 

Prerequisites 

AutoCAD: 

- Basic View Control & Editing Command 

- MTO AutoCAD Standards (IESCAD 2009) 

InRoads: 

User should be familiar with InRoads: 

- Working Environment 

- Tools 

- Surfaces 

- Features 

- Geometry 

- Template 

- Roadway Designer 

- Reports 

 

It is also recommended that the user be familiar with the following: 

- MTO InRoads Project Template 

- MTO Customization Documentation 

- MTO InRoads Standards and Preferences Manual 

Highway Design: 

- Design principles 

- MTO Design Manuals, Guidelines, and Policies 
 

Software Version  

- AutoCAD 2009 

- InRoads V8i (SELECTseries 1) 
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Design Data and InRoads Files 

The design data used in this example project is for demonstration only. Actual projects may vary.  

 

The length of this example project is 500m. 

 

 

Proposed Design 

Design Speed  

Horizontal Curve  

Spiral Parameter 

Spiral Length 

Vertical Curve K Value 

Pavement Width  

Shoulder Width 

Partially Paved Shoulder 

Shoulder Rounding  

Cross-fall  

Superelevation 

Pavement 

80 km/h  

R = 500m 

A = 150 

Ls = 45m 

30 Sag 40 Crest 

2x3.50m 

2.50m 

0.5m 

0.5m 

2% (Pavement), 6% (Shoulder) 

4.6% (Max 6%) 

Roadway: 

 40mm Asphalt Top Course 

 50mm Asphalt Base Course 

 150mm Granular A 

 300mm Granular B (earth) 

 150mm Granular B (rock) 

Partially Paved Shoulder: 

 50mm Asphalt Surface Course 

 

The files listed and described below are provided in the Example 1 data set Data1.zip:  

Existing Ground Surface (.dtm) 

 ……\Data1\Surfaces\Ex1_OG.dtm 

 

Geometry File (.alg) 

 ……\ Data1\Geometry\Ex1.alg 

 

OG Data (.soe) 

 ……\ Data1\Documentation\OG.soe 

 

Borehole Data (.txt) 

 ……\ Data1\Documentation\Borings.txt 

 

AutoCAD Drawings (.dwg) 

 ……\ Data1\Drawings\Ex1.dwg 
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The files listed and described below are located in InRoads Project Template directory structure 

(see Section 2.1): 

Inroads Template Library (.itl) 

 ……\InRoads Project Template\Standards\MTO_STD_Templates.itl 

 

MTO Preference File (.xin) 

 ……\ InRoads Project Template\Standards\ MTO_civil.xin 

 

AutoCAD Drawings (.dwg) 

 ……\ InRoads Project Template\Standards\MTO_InRoads_Template.dwg 
 

 

The following files will be created for the project design: 

Projects (.rwk) 

Roadway Design (.ird) 

Design Surfaces (.dtm) 

Reports (XML Data, .xml) 

Design Drawings (Plan, Profile, Cross Section, .dwg) 

 

Topics Covered: 

- Setting up an InRoads Project  

- Creating and Displaying Digital Terrain Models (DTMs)  

- Designing a Horizontal Alignment 

- Creating an Existing Ground Profile 

- Designing a Vertical Alignment 

- Defining a Typical Section 

- Modeling a Roadway 

- Applying Superelevation  

- Creating Design Cross Sections and Surfaces  

- Performing Quantity Computations  

- Generating Design Drawings 

- Producing InRoads Reports 

- Exporting InRoads Data for Construction 
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InRoads Master Workflow 

 

Start InRoads and Open 
MTO_InRoads_Template.dwg 

Load/Create a Project 

 

Create Existing OG 
Surface and 
Subsurface 

Create and Edit a 
Horizontal Alignment 

Create and Edit 
Vertical Alignment 

 

Extract Profiles 

 

Create and Edit 
Templates 

 

Apply Superelevation Create Design 
Surface 

Define Roadway 
Corridor 

 

Extract Cross 
Sections 
Superelevation 

Review Design 
Surface 

Computer Cut and 
Fill volumes 

Generate Drawings Archive Project Create Reports and 
Diagrams 
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2.0 InRoads Project Setup 
 

Note: All InRoads data files shall be as per the MTO InRoads Project directory structure 

posted on the MTO web site:  http://www.xfer.mto.gov.on.ca/PTASapps/index.htm 

 

This directory structure is mandatory for all in-house and service providers design work 

done with InRoads. 

 

This section describes how to set-up the InRoads project directory and file structure. 

 

2.1 Project Directory Set-up 
 

Getting started 

 

1. For this example, on your C drive create a project folder named 

InRoads Projects and then a folder named Example1 

 

The folder path should now be:  C:\InRoads Projects\Example1 

 

2. Go to the web site:  

http://www.xfer.mto.gov.on.ca/PTASapps/index.htm 

then, scroll down to find a list of InRoads files.  Click on the file 

InRoads Project Template.exe and save it to the folder called InRoads 

Projects that you created in step 1.  Click Close. 

3. Install the required directory structure by going to the folder InRoads 

Projects and clicking twice on the file InRoads Project Template.exe 

to run the file.  Click Install.  Directories will be automatically set-up 

in the InRoads Projects folder in a new folder called InRoads Project 

Template 

4. From the InRoads Project Template folder copy the following 

directories to the Example1 folder: 

- Corridors 

- Design Notes 

- Documentation 

- Drawings 

- Geometry 

- Reports 

- Standards 

- Surfaces 

Note:  For all InRoads design work, put in the project GWP/WP 

folder a folder called InRoads or something similar.  This is where the 

InRoads highway design files should be kept. 
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5. The folder Example1 will now look like this: 

 

 

 

6. Copy Example 1 data set Data1.zip to the folder Example1. Right click 

on the compressed file Data1.zip and select Extract All from the pop-

up menu. 

 

  

 

7. Follow the Extraction Wizard. When the target directory appears on 

the dialog, make sure the path is pointed to the folder Example1. 

 

 

 

8. When finish, go through each folder to verify that files are installed 

properly as described under sample data set section in Section 1. 
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9. Start InRoads V8i (SELECTseries 1) with AutoCAD 2009. 

10. Load MTO_InRoads_Template.dwg from the folder 

...\Example1\Standards into AutoCAD. 

11. Click AutoCAD’s File > Save As command to save a working 

drawing under …\Example1\Drawings. 

 

 

2.2 Project Defaults 
 

By setting up the project defaults, the user can set the default directory 

locations for opening/saving files for each design project to facilitate 

working on multiple projects. The InRoads Project Defaults command is 

used to set up default directories for all file types that can be accessed 

through the File/Open and File/Save As dialog boxes. These include 

Project (.rwk), Surface (.dtm), Geometry (.alg), Template Library (.itl), 

and Roadway Design (.ird). All other files, which are opened or saved 

throughout the program, use the Project Default Directory setting. The 

project default file directories are stored in the computer’s registry.  

 

1. Click to File > Project Defaults on the InRoads Main Menu. 

2. Click on the New button and the New Configuration dialog box will 

appear. 

3. Type in Example1 in the Name field, click OK to save and close the 

dialog box. 

 

 

 

4. Click in the Preferences (*.xin) field and click the Browse button. The 

Open dialog will appear. Browse to …\Example1\Standards folder.  

5. Select MTO_civil.xin, and click Open, 

6. Click in the Project Default Directory field and click the Browse 

button. The Open dialog will appear. Browse to …\Example1, and 

Click Open. 

Note:  MTO_InRoads_Template.dwg file contains proper layers and 

blocks to be used with MTO InRoads preference file as described in 

MTO InRoads Preference and Standards Manual. 
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7. Click in the Report Directory field and click the Browse button. The 

Open dialog will appear. Browse to …\Example1\Reports, and Click 

Open. 

8. Click in the Projects (*.rwk) field and click the Browse button. The 

Open dialog will appear. Browse to …\Example1, and Click Open. 

9. Click in the Surfaces (*.dtm) field and click the Browse button. The 

Open dialog will appear. Browse to …\Example1\Surfaces, and Click 

Open. 

10. Click in the Geometry Projects (*.alg) field and click the Browse 

button. The Open dialog will appear. Browse to 

…\Example1\Geometry, and Click Open. 

11. Click in the Template Libraries (*.itl) field and click the Browse 

button. The Open dialog will appear. Browse to 

…\Example1\Standards, and Click Open. 

12. Click in the Roadway Design (*.ird) field and click the Browse button. 

The Open dialog will appear. Browse to …\Example1\Corridors, and 

Click Open. 

13. The screen should now look like the picture shown below step 14. 

14. Click the Apply button to save the configuration, and then click the 

Close button. 
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2.3 Project Files 
 

InRoads allows users to create a project file for each project. With project 

file, the user can quickly load all files needed for a particular project. A 

project file is composed of a list of files with path names. To create a 

project file for example 1: 

 

1. Click to File > Open on the InRoads Main Menu.  

2. Change the Files of type to Surfaces (*.dtm) and select Ex1_OG.dtm. 

Click Open. 

 

 

Note:  After selecting the file type, the path will change to the 

folder as defined in the Project Defaults. 
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3. Change the Files of type to Geometry Projects (*.alg) and select 

Ex1.alg. Click Open. 

4. Change the Files of type to Template Libraries (*.itl) and select 

MTO_STD_Templates. Click Open and then Cancel. 

5. Create Project file (.rwk). Click to File > Save > Project on the 

InRoads Main Menu.  

6. On the lower right corner of the Save As dialog box, click the Options 

(…) button. The Project Options dialog box will appear.  

 

 

 

7. For Surfaces tab, check Add for the Existing surface Ex1_OG that was 

loaded in step 2. 

 

8. For the Geometry Project, XIN Preferences, and Template Library 

tabs, check Add and Update on each file listed under the File Name. 

9. Click OK button to close the Project Options dialog box. 

10. In the Save As dialog box click in the File name field and type in 

Example1. Click the Save to complete creating the project file. Click 

Cancel to close the dialog. 

Note:  Proposed surfaces will be created in the design process. 

These files will be checked with both Add and Update options. 
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2.4 Active Project Settings 
 

The Active Project Settings command displays the Active Project 

Settings dialog box, which gives you a single, convenient place for 

specifying the active surface, active geometry project, and active 

horizontal and vertical alignments. A change to any of the active settings 

is effective immediately, and other commands automatically become 

aware of the change. 

 

1. Select Tools > Application Add-ins. 

2. From the Available window on the Application Add-ins dialog, find 

and check the Active Project Settings Add-In. 
 

 

 

Note:  Project files must be maintained and updated through the 

project design process. After creating subsurfaces, running Roadway 

Designer and creating proposed surfaces, the surfaces (.dtm) and 

Roadway Design (.ird) will be added to the .rwk. 
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3. Click OK button to close the dialog. 

4. Select Tools > Active Project Settings. 

5. The Active Project Settings dialog box should be the same as shown 

below. If not, make selection with the drop-down list so it matches. 
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3.0 Creating Existing Conditions 
 

3.1 Original Ground (OG) Surface 
 

A sample existing ground surface Ex1_OG.dtm is provided with the 

sample data set. A surface can be created in several ways in InRoads. For 

demonstration, the InRoads Text Import Wizard is used to create the OG 

surface from an ASCII file.  

 

The existing ground surface information is stored in an ASCII file in 

Station, Offset and Elevation format. The file can be found under: 

…\Example1\Documentation\OG.soe. Shown below is part of the file that 

can be viewed using Notepad: 

 

 

 

This method also needs alignment information to create the surface. The 

geometry project file Ex1.alg will be used for the surface creation. 

  

 

Importing OG surface 

 

1. Before starting the process, check and make sure the alignment Ex1 is 

the active alignment (See section 2.4 Active Project Settings). 

2. From InRoads Main Menu select File > Text Import Wizard. The 

Text Import Wizard box will appear. 

3. Select Surface from the Data Type drop-down list. 

Note:  The data used to create a surface may in different format. 

Northing, Easting and Elevation is another commonly used format. 

InRoads Text Import Wizard provides the flexibility by letting you 

describe the format of files before you import them. 
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4. Click on the browse button icon  on the lower right corner. The 

Browse dialog box will appear. 

5. Browse to the Documentation folder under Example 1 project folder. 

6. Chang Files of type to All Files (*.*) 

7. Select the OG.soe file. 

 

 

 

8. Click Open to close the Browse dialog and return to the Text Import 

Wizard dialog box. The file name with the path is showing in the File 

Name field now. 
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9. Click Ok button. The Text Import Wizard – Step 1 of 4 dialog box 

will appear. Keep the default settings.  

 

 

 

10. Click Next > button. In the Text Import Wizard – Step 2 of 4 dialog 

box, select the radio buttons All Lines in the Apply Filter to field and 

Delimited – Characters separate each field in the Original Data Type 

field. 
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11. Click Next > button. In the Text Import Wizard – Step 3 of 4 dialog 

box, make sure all the setting are as shown below. 

 

 

 

12. Click Next > button. In the Text Import Wizard – Step 4 of 4 dialog 

box, click each data column and then select a Column Data Format for 

the column from the drop-down list: 

• Column 1:  Station 

• Column 2:  Offset 

• Column 3:  Elevation 
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13. Click on Save As to save the wizard for future use (optional). Provide 

a name in the Name Wizard dialog box. 

14. Click Finish button. Surface Options dialog box will appear. 

 

15. In the Surface Options dialog box, make or type the following 

selections: 

• Surface:     Ex1_OG 

• Seed Name:     og 

• Feature Style:    SP-E-GND-OG 

• Point_Type:    Random 

 

 

 

16. Click OK button. A dialog box will appear showing the surface is 

imported successfully. 

 

Note:  If you didn’t save the wizard in step 13, InRoads will ask if 

you want continue without saving the changes made from step 9 to 

12. You can select Yes to continue or select No and return to the 

import wizard step 4 dialog box to save the wizard.  
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17. Click OK to close the dialog box. Go to InRoads Explorer. In the left 

pane, select Surfaces. A new surface Ex1_OG is listed under Surfaces. 

 

 

 

18.  From InRoads Main Menu select Surface > Triangulate Surface.  

 

 

 

19. Click Apply to triangulate selected surface. 

20. Click Close to close the dialog box. 

21. Select Surface > Surface Properties. On the Main tab, type Ex1 

Existing Ground in the Description field. 
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22. On the Advanced tab, set Cross Sections and Profiles symbology to 

DTM_OG. 

 

 

 

23. Click Apply then Close. 

24. Select File > Save > Surface. The Save As dialog box will appear and 

point to the folder as defined in the Project Defaults. 

25. Accept the default surface name Ex1_OG and click Save.  

26. Click Cancel to close the dialog box. 

 

Viewing OG surface 

 

InRoads provides users several viewing tools to display the surface data 

including the perimeter, triangles, contours and features. 

1. Turn off the Style lock and select Pencil mode on the Locks toolbar. 

 

2. Select Surface > View Surface > Perimeter.  

 

Note:  If the Style lock is on, the dialog box will not appear when 

you choose one of the View Surface commands. 
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3. Click on the Preferences button. Make sure the preference MTO is 

selected. Close the Preference dialog. 

4. Select the Surface Ex1_OG from the drop-down list. 

5. Click on the Apply button and the perimeter is drawn in AutoCAD. 

Go to AutoCAD and zoom to the result. 

 

 

6. Click Close.  

7. Select Surface > View Surface > Triangles. 
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8. Click on the Preferences button. Make sure the preference MTO is 

selected. Close the Preference dialog. 

9. Select the Surface Ex1_OG from the drop-down list. 

10. Click on the Apply button and the triangles are drawn in AutoCAD. 

 

 

11. Click Close. 

12. Delete the perimeter and triangles with AutoCAD delete command. 

13. Select Surface > View Surface > Contours.  

 

 

 

14. Click on the Preferences button. Select and load the preference 

MTO_SP.  Close the Preference dialog. 

15. Select the Surface Ex1_OG from the drop-down list. 

16. Click on the Apply button and the contours are drawn in AutoCAD. 
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17. Click Close. 

18. Delete the contours with AutoCAD delete command. 

19. Select Surface > View Surface > Features. 

 

 

 

20. Select the Surface from the drop-down list. 

21. Select the Features og from the feature list window. 

22. Click Apply then Close. 

23. Feature og is drawn with style SP-E-GND-OG in AutoCAD. 
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3.2 Subsurfaces (Rock and Swamp) 
 

This example involves rock and swamp condition. The rock and swamp 

surfaces are created in the following task. The data file of borings 

containing rock and swamp information is provided with the sample data 

set. The file can be found at …\Example1\Documentation\borings.txt. 

 

The file is in ASCII format and the data format is described at the 

beginning of the file as shown below: 

 

 

 

 

1. Select Tools > Application Add-ins. 

2. From the Available window on the Application Add-ins dialog, find 

and check the Import Subsurface Add-In. 
 

 

Note:  InRoads Import Subsurface command is used in this task. 

Before using this command, you need: 

• Create/load an existing surface 

• Prepare a data file of borings with enough data to triangulate 

If using Station/Offset format for borehole location, you also need a 

horizontal alignment. 
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3. Click OK button to close the dialog. 

4. Select File > Import > Import SubSurface. 

5. Select Ex1_OG for Existing Surface and Ex1 for Horizontal 

Alignment. 

 

 

 

6. Click in the File Name field and click Browse button. 

7. In the Browse dialog, navigate to the folder 

…\Example1\Documentation and select the file Borings.txt. 

 

 

 

8. Click Open and return to the Import Subsurface dialog box. The file 

name with the path is showing in the File Name field now. 
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9. Click Apply then Close.  

10. Go to InRoads Explorer. In the left pane, select Surfaces. The Rock 

and Swamp surfaces are created under Surfaces. 

 

 

 

11. Select Surface > Surface Properties. Select Rock from the Surface 

drop-down list. 

12. On the Advanced tab, set Cross Sections and Profiles symbology to 

DTM_Rock Survey. Click Apply. 

13. Select Swamp from the Surface drop-down list. 

14. On the Advanced tab, set Cross Sections and Profiles symbology to 

DTM_Muskeg Survey. Click Apply. 

15. Click Close to close the Surface Properties dialog. 

16. Set Rock surface active and save it to project folder. 

17. Set Swamp surface active and save it to project folder. 

18. Select File > Save As to open up the Save As dialog. 

19. Change the Save as type to Projects (*.rwk) and select Example1.rwk.  

20. Click the Options (…) button on the lower right corner of the Save As 

dialog box. The Project Options dialog box will appear.  

21. Click Surfaces tab, check Add for Rock and Swamp surfaces. 
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22. Click OK button to close the Project Options dialog box. 

23. Click the Save button and confirm to replace existing project file. 

24. Click Cancel to close the dialog. 

 

3.3 View Cross Sections of the Surfaces 
 

After defining horizontal alignment, the surfaces can be viewed in cross 

sections. A geometry project Ex1.alg is provided with the sample data set 

and can be used to view the surfaces. 

 

1. Make sure the geometry project Ex1.alg is loaded and is the active 

geometry project. 

2. Select Evaluation > Cross Section > Create Cross Section.  

3. Click Preferences button.  

4. If the Active Preference is not MTO, load it. Click Close. 

5. Select General leaf. Set interval to 20 and check surface Ex1_OG, 

Rock and Swamp in the Surfaces list window. 

6. Select Source leaf. Make sure alignment Ex1 is selected. 

7. Click Apply and select an insert point in AutoCAD. 
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3.4 Generate Cross Section Reports 
 

After generating the cross section set, the Cross Section Report command 

can be used to create station, offset, and elevation report. 

 

1. Select Evaluation > Cross Section > Cross Section Report. 

2. On the Cross Section Report dialog, select Cross Section Set EX1. 

3. Select Ex1_OG from the Include Surfaces field. 

 

 

 

4. Click on Apply. 

5. In InRoads Report Browser, select CrossSectionGradbookWide.xsl 

under Evaluation. The surface is reported in Station, Elevation, and 

Offset format. 

 

 

 

6. Close the Report browser.  

7. On Cross Section Report dialog, select Rock from the Include Surfaces 

field. 

8. Click Apply. 
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9. Repeat step 6 to 8 to generate Swamp report. 

 

 

 

 

 

Note:  You can report each surface separately or select all the 

surfaces and report them in one single report. 
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4.0 Horizontal Alignments 
 

4.1 Creating Horizontal Alignment 
 

There are various methods for creating horizontal alignments in InRoads. 

In this example, the PI method for the layout of horizontal geometry is 

used. A sample drawing Ex1.dwg provided with the sample data set is 

used as a reference with PIs to be used for the alignment.  

 

 

 

Shown above is Ex1.dwg. PI-1 defines the point of beginning (POB) on 

the alignment, while PI-2 is a point of intersection (PI), and PI-3 is the 

point of ending (POE).  The Ex1.dwg file can be found at 

…\Example1\Drawings\Ex1.dwg 

 

The process described below will create a horizontal alignment same as 

provided in the geometry project Ex1.alg. 

 

1. From AutoCAD, open Ex1.dwg. 

2. In InRoads, make sure the geometry project Ex1.alg is loaded and it is 

the active geometry project. 

3. Create a new horizontal alignment under geometry project Ex1 with 

name Example1 and style PD-N-ALI-CL (alignment style for 

planning and design), and the description. 
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4. Click Apply and Close. 

5. Select Geometry > Horizontal Curve Set > Add PI. 

6. Click Snap to Endpoint icon from InRoads Snaps toolbar then 

identify the first point PI-1in AutoCAD as the beginning of the 

alignment.  

 

7. Select point PI-2 and PI-3. 

 

 

 

8. Right click twice, one to accept and another to end the command. 

9. Delete the graphics generated by Add PI command, and then redisplay 

the alignment elements. 

10. Select Geometry > Horizontal Curve Set > Define Curve. 

11. In the Define Horizontal Curve Set dialog, enter the following curve 

information in the Horizontal Curve section: Radius is 500.00m, Spiral 

Length is 45.00m. 

 

 

 

12. Click Apply. The curve with radius is shown in AutoCAD. 

Note:  Always read and follow the prompts in AutoCAD 

Command Line window. 
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13. Click Close button to close the dialog. 

14. The alignment is displayed in AutoCAD with the style set in step 3. 

 

 

 

15. Save InRoads geometry project. 

16. Save AutoCAD drawing to …Example1\Drawings\. 

 

4.2 Viewing the Active Horizontal Alignment 
 

1. Delete the graphics with AutoCAD delete command. 

2. In InRoads, select Geometry > View Geometry > Active Horizontal. 

The alignment will now be shown in AutoCAD. 

 

Note:  If the radius is too large, InRoads will not find a solution. 

Adjust the parameters. 
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4.3 Setting the Starting Station 
 

1. In InRoads, select Geometry > Horizontal Curve Set > Stationing.  

2. In the Stationing dialog enter the station value 10+000 in the Starting 

Station field. By default, the starting point is the first PI (POB) placed 

in the geometry. The Vertical and Superelevation Alignments options 

should be set to Maintain Station Difference. 

 

 

 

3. Click Apply then Close. 

4. Click File > Save > Geometry Project. 

 

4.4 Reviewing Horizontal Alignments 
 

The Review Horizontal Alignment command is used to review a selected 

geometry in detail.   

 

1. Select Geometry > Review Horizontal.  

2. In the Mode section, select Element. 

3. Click Next button to move along the alignment 

 

4. In the Mode section, select Alignment. The Review Horizontal 

Alignment dialog displays information on all the elements in the 

alignment. 

 

Shown below is the Review Horizontal Alignment dialog with the 

Alignment mode selected. The starting station (POB) is 10+000.000 as set 

in previous session. The review information can be displayed in AutoCAD 

using the Display button or saved as an ASCII file using the Save As 

button, and be used to recreate the horizontal alignment. 

Note:  As you move along the alignment, the element is 

highlighted in AutoCAD. 
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4.5 Displaying Stationing 
 

The View Stationing command is used to place station annotation text 

along the active horizontal alignment at a specified interval. 

 

1. Select Geometry > View Geometry > Stationing. 

2. Click on the Preferences button. Select and load the named preference 

MTO_Alignment_P&D.  Close the Preference dialog. 

3. Click Apply and then Close. 

4. Stationing will be generated on the Planning and Design layer as 

defined in MTO AutoCAD Standards Guide. 
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4.6 Annotating Horizontal Alignments 
 

Horizontal Annotation command is used to display and annotate 

horizontal alignments, points, and elements.  

 

1. Select Geometry > View Geometry > Horizontal Annotation 

2. Click Preferences button.  

3. On Preferences dialog, select MTO_Alignment_P&D, click Load > 

Close. 

4. Click in the Horizontal Alignments Include field. 

5. Click Filter button. 

6. On the Geometry Selection Filter dialog, select alignment Example1 

from the Available side. 

7. Click Add button to put the alignment on the Selected side. 

8. Click OK return to the View Horizontal Annotation dialog. 

9. Click Apply. The selected alignment is displayed with element data. 

 

 

 

10. Click Close. 

11. Select Geometry > View Geometry > Curve Set Annotation. 

12. Click Preferences and load named preference 

MTO_Alignment_P&D.  

13. Click Close return to Curve Set Annotation dialog. 

14. Select Example1 in the Horizontal Alignment field for annotation. 

15. Click Apply to display annotation. 
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4.7 Generating Horizontal Alignment Report 
 

The Review Horizontal command can be used to report detailed 

information about the elements in selected horizontal alignment. The 

information can be displayed in AutoCAD or saved to an ASCII file.  

Select different Mode to report different parts of the alignment. 

 

1. Select Geometry > Review Horizontal. 

2. Select Ex1 for Geometry Project and Example1 for Horizontal 

Alignment. 

3. Select Mode to review and report information in different format. 
 

 

 

 

Horizontal Alignment Report also can be generated by InRoads XML 

Reports command and used with a large number of style sheets. 

 

1. Select Tools >XML Reports >Geometry. 

2. On the Geometry Report dialog, type Example1 in the Horizontal 

Alignments Include field.  

3. Press Tab on the keyboard. The alignment Example1 will be listed in 

the Selected window. 

 

 

 

 

4. Click Apply to create the report. Bentley Civil Report Browser is 

displayed. 

5. Select HorizontalAlignmentReview style sheet. 

Note:  Filter or select button   also can be used to select 

alignments. Use * will select all the alignments in the geometry 

project.  
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6. Select Tools > Format Options in the Bentley Civil Report Browser. 

7. Make the desired changes to the format of the generated report. 

8. Select File > Save As in the Bentley Civil Report Browser to save the 

data into file with selected file type. 
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5.0 Profile and Vertical Alignment 
 

5.1 Creating Profile 
 

Before defining the vertical geometry, the existing ground profile along 

the horizontal geometry needs to be extracted from selected OG surfaces.  

 

1. Select Evaluation > Profile > Create Profile and the Create Profile 

dialog will appear. 

2. Click on Preferences button. Select and load named preference MTO. 

3. Close the Preference dialog. 

4. Click on the Source leaf. The Create field should be Window and 

Data.  

5. Check and make sure the Alignment is Example1. 

 

 

 

6. Click on General leaf. By default, the Set Name is set to the active 

horizontal alignment Example1.  

7. Make sure surface Ex1_OG is checked in the Surfaces list window. 

 

 

 

8. Click on Controls leaf. Make sure the Elevation range and Station 

range are not used. 

9. Click Apply and select an insert point in AutoCAD. 
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5.2 Updating Profile 
 

After a profile is created, Update Profile command is used to add new 

surfaces, offsets, and features to the existing profile, or refresh  surfaces, 

offsets, and features that have been modified in the existing profile.  

 

The following steps will add Rock and Swamp surfaces to the profile. 

 

1. Select Evaluation > Profile > Update Profile. The Update Profile 

dialog will appear. 

2. In the Profile Set field, if there is more than one profile set exists in the 

drawing, select the most recently created set. A yellow frame will 

appear around the selected profile set. 

 

 

 

3. Click on Surface leaf. In the Mode field, select Display On. 

4. In the available Surfaces list window, select Rock and Swamp 

surfaces. 
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5. Click Apply.  

 

 

 

5.3 Creating Vertical Alignment 
 

After extracting profile along the existing horizontal alignment, the 

vertical alignment can be defined. The following PI input will be used: 

       Station    Elevation  

10+000   296 

10+250  303.5 

10+500  298.5 

 

1. Check and make sure the horizontal alignment Example1 is the active 

alignment. 

2. Select File > New. 

3. On the New dialog, select Geometry tab. 

4. Set the dialog as following: 

• Type: Vertical Alignment 

• Name: Example1 

• Description:  Center Line Finished Grade 

• Style: PD-N-ALI-CL 

• Curve: Parabolic 

Note:   
Refresh - replaces previously displayed graphics with up-to-

date data. 

Display On - displays graphics not currently exist in the 

profile. 

Display Off - removes graphics (surfaces or features) from 

the profile. 
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5. Click Apply and Close. 

6. Check InRoads Explorer, make sure vertical alignment Example1 is 

created under alignment Example1 and is active. 

7. Select Geometry > Vertical Curve Set > Dynamics Settings. 

8. On Dynamics Settings dialog, toggle on Station and type 50 in the 

Station input field. 

9. Toggle on Elevation and type 0.5 in the Elevation input field. 

 

 

 

10. Click Apply. 

11. Select Geometry > Vertical Curve Set > Add PI. 

12. Follow the prompt in AutoCAD Command Line, pick the first point in 

the profile window at the profile start point station 10+000 around 

elevation 296.  
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13. Follow the message in the bottom portion of InRoads Explorer 

window, move the cursor in the profile window to the point at station 

10+250 and elevation 303.5, then click to accept. 

 

 

 

14. Move the cursor in the profile window to the profile end at station 

10+500 and elevation 298.5, and then click to accept. 

 

 

 

15. Right click twice to end the command. 

16. Close the Dynamics Settings. 

17. Select Geometry > Vertical Curve Set > Define Curve. 

18. In the Vertical Curve section on the Define Vertical Curve Set dialog, 

set Calculate By to K = l / (g2 - g1) and for K Value, enter 40. 

 

Note:  The Station and Elevation (toggled on) are rounded up or 

down to the nearest value as specified in the data fields on the 

Dynamics Settings dialog. 
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19. Click Apply. The defined vertical curve is displayed and highlighted 

in the profile window. 

 

 

 

20. Click Close to dismiss the dialog box. 

21. Save the geometry project. 

 

5.4 Reviewing Vertical Alignment 
 

After creating the vertical alignment, the Review Vertical Alignment 

command can be used to display information about the geometry of the 

active vertical alignment. The vertical alignment review information can 

be displayed in AutoCAD or saved as an ASCII file. 

 

1. Select Geometry > Review Vertical. 



 

 
InRoads Typical Example 1 – Version 1.0                                                                         Page 43 

 

 

2. In the Mode section, select Element. 

3. Click Next button to move along the alignment. 

 

4. When finish close the dialog. 

 

 

5.5 Displaying Vertical Alignment 
 

The Active Vertical command is use to display the active vertical 

alignment without annotation. The geometry style associated with the 

alignment when they are created will be used for displaying. 

 

Select Geometry > View Geometry > Active Vertical. 

 

Note:  As you move along the alignment, the element is 

highlighted in the profile window. 
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5.6 Annotating Vertical Alignment 
 

Use the Vertical Annotation command for more detailed annotation and 

display. Predefined preference is used to display the alignment points, 

tangent lines and vertical curves, and annotate the geometry. 

 

1. Select Geometry > View Geometry > Vertical Annotation. 

2. Make sure both the Horizontal Alignment and Vertical Alignment are 

Example1. 

3. Click Preferences.  

4. Select named preference MTO_Proposed and Load it. 

5. Close Preferences dialog 

6. Click Apply. 

 

 

 

7. Use AotoCAD command to zoom in and view annotation. 

8. Close the View Vertical Annotation dialog box. 

 

5.7 Generating Vertical Alignment Report 
 

The Review Vertical command can be used to report detailed information 

about the geometry of the active vertical alignment. The information can 
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be displayed in AutoCAD or saved to an ASCII file. Select different Mode 

to review alignment or element information. 

 

1. Select Geometry > Review Vertical. 

2. Select Ex1 for Geometry Project, Example1 for Horizontal Alignment 

and Example1 for Vertical Alignment. 

3. Select Mode to review and report information in different format. 

 

 

 

 

Vertical Alignment Report also can be generated by InRoads XML 

Reports command and used with a large number of style sheets. 

 

1. Select Tools >XML Reports >Geometry. 

2. On the Geometry Report dialog, type Example1 in the Horizontal 

Alignments Include field. 

3. Press Tab on the keyboard. The alignment Example1 will be listed in 

the Selected window. 

4. Check on the Include Vertical Alignments section. 

5. Toggle on the Active option. 
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6. Click Apply. Bentley Civil Report Browser is displayed. 

7. Select VerticalAlignmentReview style sheet 

 

 

 

8. Select Tools > Format Options in the Bentley Civil Report Browser. 

9. Make the desired changes to the format of the generated report. 

10. Select File > Save As in the Bentley Civil Report Browser to save the 

data into file with selected file type. 
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6.0 Typical Sections 
 

6.1 Setting Up Project Template Library 
 

MTO standard template library contains predefined typical sections, 

components, and a point name list that point names are associated with 

MTO standard symbology. The template can be used to create project 

specific template library. 

 

1. Select File > Save As. 

2. On the Save As dialog, Change the Save as type to Template Libraries 

(*.itl). 

3. In the File name field, type in Example1. 

4. Click Save. A new template library Example1 is saved to the proper 

project folder as defined in project default. 

 

 

 

5. On the Save As dialog, Change the Save as type to Projects (*.rwk). 

6. Select Example1.rwk from the file list window. Example1.rwk will 

appear in the File name field. 
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7. Click Options then select Template Library tab. 

8. On Project Options dialog, check both Add and Update options. 

 

 

 

9. Click OK to close the Project Options dialog. 

10. Click Save then Yes to confirm replace the existing project file. 

11. Click Cancel to close the Save As dialog. 

 

12. Select Modeler > Create Template. The Create Template dialog will 

appear. 

13. Select File > New > Folder. 

14. Type in Example1 for the name of the new folder in the Template 

Library window. 

 

 

 

15. Double click on MTO Library > Complete Templates > Inner 

Lane. 

Note:  MTO standard template library can be copied to the project 

template library and added to the project file as described in section 

2.3. 
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16. Select template Type 3. 

 

 

 

17. Select Edit > Copy. 

18. Select folder Example1.  

19. Select Edit > Paste. 

20. Double click folder Example1. The standard template is copied to 

folder Example1. 

 

 

 

21. Click File > Save. 

 

 

6.2 Developing Example 1 Template 
 

In previous section, a template is selected from MTO standard templates 

library and copied to the project template folder. This template is going to 

be modified to meet the specific project requirements. 

 

1. Select the new copied template Type 3 in the Example1 folder.  

2. Select Edit > Rename. 

Note:  Project specific templates should be created/copied and 

modified in the project specific folder. 
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3. Type in a new name: Example1 Rock/Swamp. 

4. Give additional information in the Description field in the Current 

Template section. 

 

 

 

5. Click File > Save. 

 

6. Change shoulder width to proposed design. In the template display 

window, find and double click on the point L-TP-ES. On the Point 

Properties dialog, go to Constraints section. Type -2.50 in the Value 

field for the Horizontal constraint. 

 

 

 

7. Click Apply Then Close. 

8. Find and double click on the point R-TP-ES in the template display 

window. Type 2.50 in the Value field for the Horizontal constraint. 

Note:  During the process of customize the project template, save 

the template library when the modification is worth saving. 

Refer to Proposed Design in section 1 for parameters to be used in 

the project template. 
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9. Similarly, for partially paved shoulder width set Horizontal Constraint 

value to -0.5 for point L-TP-EPS, and 0.5 for R-TP-EPS. 

10. Change depth of asphalt top and base courses.  

a) Set Vertical constraint value to -0.04 for point L-AB1-EP, AB1-CL, 

and R-AB1-EP. 

b) Set Vertical constraint value to -0.05 for point L-TA-EP, TA-CL, 

and R-TA-EP. 

11. Modify the shoulder on the left side. Zoom in and right click on L-

AB1-EP. Select Delete Point from the pop-up menu. 

 

 

 

12. From the Delete Point dialog, select L-Asphalt Shoulder Top Course 

from the list window. 
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13. Click OK. The point L-AB1-EP is deleted from the partially paved 

shoulder component. 

 

 

 

14. Right click on the line between points L-PPS1-EPS and L-TP-EP. 

From the pop-up menu select Insert Point. 

 

 

 

15. Move the active point curser on to the line between points L-TP-EP 

and L-AB1-EP, then click. A new point is added to the shoulder 

surface course component. 
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16. Right click on the point and select Finish from the pop-up menu. 

 

 

 

17. Double click on the newly created point. The Point Properties dialog 

will appear.  On the Point Properties dialog, select EP from the Name 

drop-down list. 

 

 

 

18. The Name field is populated with the selected name EP and the 

Surface Feature Style is changed to the style associated with the point 

name EP. 
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19. Rename the point name to L-PPS1-EP. Click Apply. Set the point 

constraints as following. 

 

 

 

20. Click Apply then Close. 

 

 

 

21. Set Vertical constraint value to -0.05 for point L-PPS1-EPS. 

22. Right click between the shoulder top course and base course 

components. Select Delete Component from the pop-up menu. 
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23. From Component Selection dialog, move the curser to select L-Asphalt 

Shoulder Base Course from the list. The component is highlighted in 

the template display window. 

 

 

 

24. Click on the selected component to delete it. 
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25. Right click on point L-AB1-EP and select Delete Point.  

26. Select L-Granular Shoulder from the list then click OK. 

 

 

 

27. Right click on point L-TA-EP and select Delete Point. 

28. Select L-Granular Shoulder from the list then click OK. 

 

 

 

29. Right click on point L-PPS2-EPS and select Delete Point. 

 

 

 

30. Right click on point L-TP-EP and select Delete Point. 

31. Select L-Granular Shoulder from the list then click OK 
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32. Right click on the line between points L-PPS1-EPS and L-TA-EP. 

From the pop-up menu select Insert Point. 

33. Move the active point curser on to the point L-PPS1-EP then click. A 

new point is added to L-Granular Shoulder component at L-PPS1-EP. 

 

 

 

34. Right click on the point and select Finish from the pop-up menu. A 

green cross is shown on the point L-PPS1-EP. 

 

 

 

35. Right click on the point L-PPS1-EP and select Merge Points from the 

pop-up menu. 
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36. Select point L- From the Delete Point dialog.  

 

 

 

37. Click on the selected point to delete it. 

 

 

 

38. Repeat steps from 11 to 37 to modify the shoulder on the right side. 
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39. Change the Vertical Constraint value to -0.09 for both points L-TA-

AUX and R-TA-AUX. 

40. Right click on point L-TA-ER and select Edit Point. Set the point 

constraints as follow: 

 

 

 

41. Select point R-TA-ER and set the point constraints as follow: 

 

 

 

 

Note:  When modify an existing templates, some point constrains 

may get lost because of deleting other points. Make sure proper 

constraints are maintained. 
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42. Verify that the Vertical Constraint value is 0.15 for points L-TB-EP, 

TB-CL, R-TB-EP. 

43. Set the Vector-Offset constraints for L-SG-GR and R-SG-GR as 

follow: 

 

        

 

 

Rock Shatter Components 

 

1. Delete both L-Rock Shatter and R-Rock Shatter components from the 

template. 

 

 

 

2. Insert R-Rock Shatter component from End Conditions folder in 

MTO library using the predefined component Rock Shatter – Inner 

Lanes. Drag and drop the component under Granular B component and 

slightly right of the centerline so the prefix “R-“ is attached to the  

point name. Select R-Rock Cut1 as its parent component. 
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3. Find points R-SH1, R-SH2, R-SH3 and R-SH4 to the right of the 

centerline from the component inserted in step 2, and set constraints 

as: 

R-SH1 

 

 

R-SH2 

 

 

R-SH3 

 

 

R-SH4 
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4. Insert L-Rock Shatter under Granular B component and slightly left 

of the centerline. Select L-Rock Cut1 as its parent component. Delete 

points L-SH2, L-SH3, L-SH10 and L-SH11. 

 

 

 

5. Set constraints for points L-SH1 and L-SH4 as: 

L-SH1 

 

 

L-SH4 
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6. Add a Null Point to check the rock presence for component L-Rock 

Shatter. Right click in the template edit window, from the pop-up 

menu, select Add New Component > Null Point. Move the cursor to 

point L-SH12 and click on it. Set the newly created null point as 

shown below. 
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7. Click on point L-SH1 and change the constraints as follow: 

L-SH1 

 

 

8. Right click in the template edit window, from the pop-up menu, select 

Add New Component > Null Point. Move the cursor to point R-

SH12 and click on it. Set the newly created null point as shown below. 

 

 

 

9. Click on point R-SH1 and change the constraints as follow: 

Note:  The target surface name rock for the Project To Surface 

constraint is typed in by user and will be used as a Target Alias. 
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R-SH1 

 

 

10. Edit point properties for points L-DI, L-DO, R-DI and R-DO to turn 

off the Check for Interception option in the End Condition 

Properties field. Do not change the constraints. 

 

 

 

11. In order to make rock shatter components (left & right) work properly, 

display rules need to be added to the template. Double click on the L-

Rock Shatter component, and then click the Edit button. The 

Component Display Conditional Expression dialog appears. Click Add 

button to add following display rules. 
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Select rules from the Template Display Rules list to construct the 

conditional expression for L-Rock Shatter as shown below: 

 

 

 

Select rules from the Template Display Rules list to construct the 

conditional expression for R-Rock Shatter as shown below: 

 

 

 

 

Components Over Swamp 

 

1. Add an End Condition to check the swamp presence. The Swamp 

Check component will be based off the L-SG-GR point. Zoom in to 

the point L-SG-GR.  

2. Right click and select Add New Component > End Condition. Give 

the component a name Swamp Check and set the Style as Muskeg. 

The Target Type set to Surface and type swamp in the Surface field. 



 

 
InRoads Typical Example 1 – Version 1.0                                                                         Page 67 

 

 

 

 

3. In the template edit window, give two points to define the end 

condition. Move the point curser close to the point L-SG-GR and 

click, then move the point curser close to the point L-TS1 and click. 

Right click and select Finish from the pop-up menu. Double click on 

the end condition component created just now. The component will 

have the following properties: 

 

 

 

4. Edit the component points. The first will be constrained to the L-SG-

GR point with 0.001 meter vertical offset. Double click on the first 

point and set the point name and constraints as follow: 

 

Note:  The target surface name swamp in the Surface field is typed 

in by user and will be used as a Target Alias. 
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5. Double click on the second point and set the point name and 

constraints as shown below. The End Condition Properties should 

select Check for Interception, End Condition is Infinite and Do not 

Construct.  
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6. Right click and select Add New Component > Constrained (or 

Unconstrained) to create a closed shape component and name it 

Swamp Excavation. Make this component as the child component of 

the Swamp Check component. The two lower points of this component 

will be called ToFirmBottom and two up points will be called ToOG. 
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7. Set the component and point properties as follow: 

       

     Swamp Excavation 

 

 

L-ToFirmBottom 

 

 

 

Note:  If you set the Project To Surface constraint before the other 

constraint which defines the projection direction, the component 

may not look exactly the same as it was shown in step 6. This will 

not affect the component behaviour in Roadway Designer. 
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R-ToFirmBottom 

 

 

L-ToOG 
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R-ToOG 

 

 

8. For Swamp Excavation, two more child components need to be 

created: 

• Swamp Backfill 

• Fill (Earth fill 2H: 1V) 

 

a) Swamp Backfill component: 

The two lower points will be the point L-ToFirmBottom and the point 

R-ToFirmBottom. Two up points L-MU-OG and R-MU-OG are 

constrained with 2:1 slope from L-SG-GR and R-SG-GR respective. 

Both points are projected to OG surface. 
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The Swamp Backfill component will have Muskeg Backfill for Style 

and Swamp Excavation for Parent Component.  

 

 

 

Point L-MU-OG and R-MU-OG are set as shown below. The surface 

name for the Project To Surface constraint is typed in by user and used 

as a Target Alias (work with multiple surfaces without having to 

modify the template from the template library). 

 

L-MU-OG 
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R-MU-OG 

 

 

b) Fill component 

Create the Fill component from the subgrade layer. All the points on 

the subgrade layer will be used as Fill component upper points. There 

are five lower points are added to the component. From left to right 

they are L-EF-OG, L-EF-EP, EF-CL, R-EF-EP, and R-EF-OG. All 

the points are projected to OG surface. Points L-EF-OG and R-EF-

OG are constrained with 2:1 slope from L-SG-GR and R-SG-GR 

respective. Points EF-CL, L-EF-EP, and R-EF-EP are horizontal 

constrained to EP and CL points. 
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The Fill component will have Fill for Style and Swamp Excavation for 

Parent Component. 

 

 

 

Points L-EF-OG, L-EF-EP, EF-CL, R-EF-EP, and R-EF-OG are set as 

shown below. The surface name for the Project To Surface constraint 

is typed in by user and used as a Target Alias 

 

L-EF-OG 
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L-EF-EP 

 

 

EF-CL 
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R-EF-EP 

 

 

R-EF-OG 
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9. For Swamp treatment, two components for backfill with swamp 

material (none embankment) need to be created: 

• L-Swamp Backfill 

• R-Swamp Backfill 

 

a) L-Swamp Backfill 

Start from L-ToFirmBottom point, gp through the point L-MU-OG, 

and then go to the final point L-SwampBackfill. The point L-

Swampbackfill located on the left side of the point L-ToOG with 0.5:1 

slope from the point L-ToFirmBottom and project to the OG surface. 

 

 

 

The component and the point properties are set as: 

 

Component L-Swamp Backfill 
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Point L-Swamp Backfill 

 

 

b) R-Swamp Backfill 

Start from R-ToFirmBottom point, gp through the point R-MU-OG, 

and then go to the final point R-SwampBackfill. The point R-

Swampbackfill located on the right side of the point R-ToOG with 

0.5:1 slope from the point R-ToFirmBottom and project to the OG 

surface 
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The component and the point properties are set as: 

 

Component R-Swamp Backfill 

 

 

Point R-Swamp Backfill 
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7.0 Roadway Modeling 
 

7.1 Roadway Designer Overview 
 

InRoads Road Designer is a highly interactive work flow that allows user 

to perform a majority of the road design functions. The main dialog has 3 

views in standard mode and 4 views in superelevation or overlay mode. 

User will see the design results simultaneously in plan, profile, and the 

cross section at the current station. This command is also used to create 

new design surfaces that represent a new roadway or other type of surface. 

 

Before running Roadway Designer, you must have: 

• A horizontal and vertical alignment or a surface feature that defines 

the location of the roadway. 

• One or more existing surfaces. 

• One or more templates to define the proposed typical section(s). 

 

7.2 Creating Corridor 
 

1. Select Modeler > Roadway Designer. The Roadway Designer dialog 

appears with three view windows. 

2. Select Corridor > Corridor Management. 

3. On the Manage Corridors dialog, type Example1 in the Name field. 

4. Set the Surface Symbology to DTM_Proposed. 

5. Set the Type to Alignment. 

6. Select Example1 for the Horizontal Alignment. 

7. Select Example1 for the Vertical Alignment. 

8. PI Rounding Tangent set to 0.000 

9. Toggle off the station Limits for apply to the entire alignment. 

10. Click Add to create the corridor. 
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11. Click Close to dismiss Manage Corridors dialog. 

 

 

 

12. Click File > Save As. The Save Roadway Design As dialog will 

appear. The location will be …\Example1\Corridors as defined in the 

project default. 

13. For Save as type, select Roadway Design (*.ird). 
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14. For File name, type Example1. 

15. Click Save and close the Save As dialog. 

16. Go to InRoads main menu, select File > Save As to update the project 

file with newly created Roadway Design file. 

 

7.3 Inserting Template Drops 
 

With an active corridor in place, the template drops can be added to the 

roadway design. 

 

1. On the Roadway Designer dialog, select Corridor > Template Drops. 

The Template Drops will appear. 

2. In the Library Templates window, select Example1 > Example1 

Rock/Swamp. The template that was created in section 6.2. 

3. Change the Interval to 10 and the Station should be 10+000.000.  

4. Click Add. The selected template is added to the Current Template 

Drops list. 

 

 

 

5. Close the Template Drops dialog. 
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6. Click File > Save to save the roadway design file with template drops. 

 

7.4 Applying Superelevation 
 

Superelevation is used to control the control the cross-fall of roadways in 

areas of horizontal curves. InRoads provides tools to create, display, and 

report Superelevation in the roadway design process. 

 

1. Select Tools > Application Add-Ins. From the Available list window 

on Application Add-Ins dialog, find and check the Variable Manager 

Add-In. 

 

 

 

2. Select Tools > Variable Manager. From the Variable Manager 

dialog, find and turn on the Modeler – 1% Superelevation Points. 
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3. Select Modeler > Roadway Designer. 

4. Click on the Process All button and set the Display Mode in the lower 

right corner to Superelevation. 

 

 

 

5. Select Superelevation > Create Superelevation Wizard > Table. 

The Table Wizard dialog will appear. 

6. Click the browse button icon  to the right of the Table input field. 

The Open Superelevation Table dialog box will appear. 

7. Navigate to …\Example1\Standards folder. Select the superelevation 

table MTO_06_80k.sup. 
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8. Click Open. 

9. Calculate the tangent runout and enter in the Specify Runout input 

field. Tangent Runout L= 400 * 0.02 * 3.5 = 28m. 

 

10. Click on Load Values From Table button. The maximum 

Superelevation Rates are read from the ASCII file specified in the 

Table field. 

 

 

 

Note:  400 is the transition rate to be used for MTO standards; 

            0.02 is the difference between normal crown and 0% slope; 

            3.5m is the width of cross section to be superelevated. 
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11. Click Next. On the Superelevation Section Definitions dialog, click 

Add button 

12. On the Add Superelevation Section dialog, accept the default Name to 

be Section1. Make the following selections: 

• Crown Point: TP-CL 

• Left Range Point: L-TP-EP 

• Right Range Point: R-TP-EP 

 

 

 

13. Click OK button to accept the inputs and return to Superelevation 

Section Definitions dialog.  

14. Click Next button then click on the Finish button on the 

Superelevation Controls dialog. Two superelevation control lines are 

created for points L-TP-EP and R-TP-EP.  
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15. Set the Display Mode in the lower right corner to Normal to view the 

complete template and all layers. Review sections in both tangent and 

curves. All layers under pavement except for the subgrade are 

superelevated appropriately. The subgrade, partially paved shoulder, 

granular shoulder and granular A layer under shoulder will be treated 

separately. 
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Subgrade Superelevation 

 

1. Select Corridor > Template Drops. Select Example1 Rock/Swamp 

under the Current Template Drops list and then click on the Delete 

button.  

2. From the Library Templates window, Select MTO Library > 

Complete Templates > Inner Lane > Type 1,2,2A,3 SG Sub for 
Supers. Then click Add. 

 

 

 

3. Close the Template Drops dialog and return to Roadway Designer 

dialog. The subgrade layer is added to the current model. 
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4. Superelevation > Create Superelevation Wizard > Table. Follow 

the wizard define a new section of superelevation for subgrade 

template using the same values used for the complete template. Set the 

points as shown below. Then click OK. 

 

 

 

5. Click Next button on the Superelevation Section Definitions dialog 

then click Finish button on the Superelevation Controls dialog. The 

subgrade layer is now superelevated. The subgrade layer must be 

edited to follow MTO standards. 
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6. Switch to Superelevation mode. Select the superelevation diagram 

view. Locate the point at 0%. Right click on it. From the pop-up menu, 

select Delete Point. Then select the Section2 line. 

 

 

 

 

 

7. Right click on the 1% point and then select Move Point from the pop-

up menu. Select the Section2 line. The Dynamics Setting dialog will 

appear. Set the Step to 1% and make sure both Snap To options 

Cardinal Points and Superelevation Points are selected. Move the 

cursor until the cursor hits the constant -3% value to be maintained at 

the 1% point from the Section1 line. 
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8. Right click on the Section2 line between the -3% point and 3% point. 

Select Insert Point from the pop-up menu then select the Section2 

line. Move the cursor to the 2% point from the Section1 line. 
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9. Repeat the same steps for the outgoing superelevation behaviour. 

 

 

 

10. Select Superelevation > Apply Shoulder Rollover Lock. On the 

Apply Shoulder Rollover Lock dialog, select Shoulder Point L-SG-

AUX. Set the slope Difference to 4% and Maximum Slope to -3% on 

the High Side. Set the slope Difference to 0% on the Low Side. Click 

on Apply. 

 

 

 

11. Apply the same settings to R-SG-AUX then close the dialog. 

12. Set the Display Mode in the lower right corner to Normal. Select 

Corridor > Template Drops and delete the current template drop from 

the list. 
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13. Select the Example1 Rock/Swamp template from the Example1 

directory and then click on Add. Now the subgrade layer is 

superelevated appropriately. 
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Shoulder Superelevation 

 

1. The partially paved shoulder, granular shoulder and granular A layer 

under shoulder on the high side of the superelevation must be properly 

superelevated to follow MTO standards. Select Superelevation Mode 

and then select Superelevation > Create Single Control Line. 

2. On the Create Superelevation Control dialog, type R-Partially Paved 

Shoulder in the Name field. Select Section1 as Parent Section (or 

leave blank). Select Section1 TP-CL-R-TP-EP from the Copy From 

drop-down list. Set Normal Crown to -6% and Maximum Cross to 

4.6%, and then click OK. 

 

 

 

3. Select Superelevation > Create Single Control Line. On the Create 

Superelevation Control dialog, type R- Granular Shoulder in the 

Name field. Select Section1 as Parent Section (or leave blank). Select 

Section1 TP-CL-R-TP-EP from the Copy From drop-down list. Check 

the Copy Values from Original option, and then click OK. 
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4. Right click on the superelevation diagram. Select Superelevation 

Display List from the pop-up menu.  

 

 

 

5. On the Superelevation Display List dialog, select R-Granular 

Shoulder from the Available Superelevations list. Click Apply and 

Close. 

 

 

 

6. In the superelevation diagram view, only the selected control line R-

Granular Shoulder is displayed. The -2%, 0%, 1%, 2% and 4.6% point 

are copied from the R-TP-EP control line. 
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7. Right click on the line between 2% and the 4.6% point. Select Insert 

Point from the pop-up menu. Insert a point at 4% Cross Slope. 

 

 

 

8. Right click on the newly created 4% point, then select Edit Point. On 

the Superelevation Point Properties dialog, set Conctraint1 to Vector-

Offset and select the 2% and 4.6% points as Parent 1 and Parent 2. 

The Value should be 0. Click on Apply. 

 

 

 

 

9. Repeat the same steps for the outgoing superelevation control points.  
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10. Delete the two 4.6% points from the control line. 

 

 

 

11. Right click on the first point and select Edit Point. The Superelevation 

Point Properties dialog appears. Use the <Previous and Next> button 

navigate through entire control line and change the Cross Slope value 

as list below: 

 

Exist Cross Slope New Cross Slope 

-2% -6% 

0% -4% 

1% -3% 

2% -3% 

4% -2% 
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12. Select Superelevation > Create Single Control Line. On the Create 

Superelevation Control dialog, type R-Shoulder Top A in the Name 

field. Select Section1 as Parent Section (or leave blank). Select 

Section1 TP-CL-R-TP-EP from the Copy From drop-down list. Set 

Normal Crown to -6% and Maximum Cross to -3%, and then click 

OK. 
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13. Right click on the superelevation diagram. Select Superelevation 

Display List from the pop-up menu. Select All and click Apply to 

display all the superelevation control lines within the current mode. 

 

 

 

14. Switch back to Normal mode. All the shoulder superelevation control 

lines are created now. Next, proper point controls have to be set up 

before these controls can take effect. 

15. Select File > Save to save changes made to the Roadway Designer 

file. 

 

7.5 Point Controls 
 

Point controls are used to modify the behavior of points in a template. 

Depending on the Mode selected, different control types can be applied to 

a point. Superelevation control lines are used as vertical point controls. 

 

1. Select Corridor > Point Controls. The Point Controls dialog appears. 

The superelevation control lines created with the superelevation 

wizard in previous section are automatically added to point control list 

as vertical controls. See below. 

   



 

 
InRoads Typical Example 1 – Version 1.0                                                                         Page 101 

 

 

2. The superelevation control lines created with Create Single Control 

Line command can be used for point control through the Point 

Controls dialog. On the Point Controls dialog, select R-TP-EPS from 

the Point drop-down list. Set the Mode to Vertical. Then select 

Superelevation for Control Type, R-Partially Paved Shoulder for 

Superelevation, and R-TP-EP for Reference Point. Click Add. 

 

 

 

3. Select R-TP-ES from the Point drop-down list. Set the Mode to 

Vertical. Then select Superelevation for Control Type, R-Granular 

Shoulder for Superelevation, and R-TP-EPS for Reference Point. 

Click Add. 
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4. Select R-TA-AUX from the Point drop-down list. Set the Mode to 

Vertical. Then select Superelevation for Control Type, R-Shoulder 

Top A for Superelevation, and R-TA-EP for Reference Point. Click 

Add. 

 

 

 

5. Three vertical controls for shoulder superelevation are added to the 

point control list. 

 

 

 

 

 

6. Close the Point Controls dialog. Select File > Save to save the 

changes. 

7. View the complete template and all layers in Normal Display Mode. 

Review sections in both tangent and curves. All layers are 

superelevated appropriately. 

Note:  Additional point controls can be added for project design 

requirements. 
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7.6 Rock and Swamp Treatments 
 

The target surface names og, rock and swamp used for creating the 

template are to be used as a Target Alias.  

 

1. Select Tools > Target Aliasing. The Target Aliasing dialog box 

appears.  

2. Click in the Target field, then select og from the list. 

 

  

 

3. Select Surface – Ex1_OG form the Surface or Corridor list window on 

the left side of the Target Aliasing dialog. 

 

 

 

4. Click Add button, the selected surface will appear to the right side of 

the dialog in the Aliases list window.  



 

 
InRoads Typical Example 1 – Version 1.0                                                                         Page 104 

 

 

5. Click in the Target field, then select rock from the list. 

6. Select Surface – Rock form the Surface or Corridor list window on the 

left side of the Target Aliasing dialog. 

7. Click Add button to add the surface Rock to the Aliases list on the 

right side of the dialog. 

 

 

 

8. Click in the Target field, then select swamp from the list. 

9. Select Surface – Swamp form the Surface or Corridor list window on 

the left side of the Target Aliasing dialog. 

10. Click Add button to add the surface Swamp to the Aliases list on the 

right side of the dialog. 

 

 

 

11. Click OK to close the dialog box. 

12. In the Roadway Designer dialog, verify that the Active Surface is the 

existing ground surface 

 

 

 

 

Swamp Treatment 

 

The OPSD 203.010 Embankments Over Swamp is used for the swamp 

treatment. The swamp is assumed to be excavated to firm bottom.  
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1. In the Cross Section Display window, navigate to the station range 

10+080 to 10+160 where the subsurface Swamp is presented.  

 

 

 

All the surfaces are shown in the cross section. The OG surface (top 

line) is in green, the swamp surface (middle line) is in magenta and the 

rock surface (bottom line) is in yellow. The swamp components 

(excavation, embankment, backfill etc.) are also shown in the cross 

section now. 

2. Go through each section that involves swamp condition. Between 

station 10+080 and station 10+120, left side end conditions need to be 

altered to reflect the embankment over swamp.  
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3. Record the station range then select Corridor > End Condition 

Exceptions to open the End Condition Exceptions dialog. 

 

 

 

4. In the Station Range field of the dialog, give the Start station 10+080 

and Stop station 10+160 as recorded. Select Left Override option in the 

Apply To field. 

5. Click Add to create the end condition exception for the given station 

range. 
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6. Click Edit button to open the template edit dialog. 
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7. In the edit window, zoom in to the left side end condition. Right click 

on the earth cut component (in green), from the pop-up menu select 

Delete Component. 

 

  

 

8. The selected component is deleted from the template. Click OK to 

return to the End Condition Exceptions dialog. 

 

 

 

9. Click Close to return to Roadway Designer. Go through the swamp 

area again and verify the changes made to the left side end conditions. 
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Rock Treatment 

 

The following OPSDs are used for this example. 
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Rock in roadway cuts shall be treated. Rock treatment typically includes a 

uniform minimum depth of 300mm rock shatter below the theoretical rock 

subgrade. Granular B depth will be 150mm for rock subgrade. The 

transition treatment depth t, a typical frost depth 2m in MTO northeast 

region is used for this example. 

    

1. In the Roadway Design, go through the cross sections. Find and record 

the rock cut station range.  

a) There are two sections within the corridor involve rock cut. They 

are from 10+180 to 10+200 and from 10+270 to 10+370. 

b) The 20m rock cut for the first section from 10+180 to 10+200 only 

appear within the side slope and ditch area and in short distance, 

no transition will be made to the sub-base (Granular B remain the 

same depth 300mm). 
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c) The last section at station 10+370 has rock cut only in side slope 

and ditch area, the granular B depth will remain at 300mm. 

 

 

 

d) For the rest sections between station 10+270 and 10+360, granular 

B depth will change to 150mm.  

Select Tools > Parametric Constraints. The Parametric 

Constraints dialog will appear. On the dialog, set the values in the 

input field as following: 

 

 

 

Click Add button on the right side to add a new entry then click 

close to return to roadway designer. 

e) The granular B depth changed to 150mm now in the given range 

from 10+270 to 10+360. The rock cuts within this range involve 

both partial and full width rock shatter. 
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2. A new template needs to be designed to provide transition from rock to 

earth as per OPSD 205.030. Granular B will have different depth for 

rock and earth subgrade. Assume rock fill will be used for the 

treatment with in the depth t (2m). 

 

 

3. Close and save the Roadway Designer.  

4. Select Modeler > Create Template to open the Create Template 

dialog. 

5. Select the template Example1 Rock/Swamp from the Template 

Library on the left side of the dialog. Right click on the template then 

click Copy on the pop-up menu.  
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6. Right click on the folder Example1 then click Paste on the pop-up 

menu. 

 

 

 

7. Right click on the newly copied template and click Rename on the 

pop-up menu. 
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8. Type in a new name Transition. 

 

 

 

9. Give additional information in the Description filed for template 

Transition. 

 

 

 

10. To make the template simple, delete all the swamp relate components 

(No need for this section). These include component Swamp Check, 

L-Swamp Backfill, R-Swamp Backfill, Swamp Excavation, Fill, 
Swamp Backfill.   

 

 

 

11. Since the rock cut and transitions are all within the full superelevation 

range, the actual Crown Point for the subgrade will be the point R-SG-

EP. To accommodate the transition for granular depth from 150mm to 

300mm, add two auxiliary points on each side of the crown point R-

SG-EP on the subgrade layer.  

Right click on point L-SG-AUX, select Delete From Components 

(Make Null) from the pop-up menu. 
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Repeat the above process to make points L-SG-EP, SG-CL, R-SG-EP, 

and R-SG-AUX to Null points. 

 

 

 

12.  Add point L-SG-AUX1 to component Granular B with Point 

Properties set as: 
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13. Add point L-SG1 and L-SG2 to component Granular B between L-

SG-AUX and R-SG-EP with Surface Feature Style set to Auxiliary. 

These two points are used for granular B transition on the left side of 

the crown point. 

Point Constraints are set as: 

 

L-SG1 
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L-SG2 

 

 

 

 

14. Insert point R-SG-EP1 to component Granular B with Surface 

Feature Style set to Edge of Pavement  and point Constraints set as: 

 

R-SG-EP1 

 

 

The Vector-Offset constraint (Constraint 2) can be input manually or 

set by using the Value Equation dialog. Click on the   button on the 

right side of the input field, and then select value from the drop-down 

list on the Value Equation dialog. 
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15. Move point R-RK-CHK to the right and right under point R-SG-EP.  

Change the point Constraints as shown below: 

 

R-SG-EP1 

 

 

 

 

16.  Add point R-SG1 and R-SG2 to component Granular B between R-

SG-EP and R-SG-AUX with Surface Feature Style set to Auxiliary. 

These two points are used for granular B transition on the right side of 

the crown point. 

Point Constraints are set as: 
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R-SG1 

 

 

The Vector-Offset constraint (Constraint 2) set as: 

 

 

 

R-SG2 

 

 

The Vector-Offset constraint (Constraint 2) set as: 
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17. Insert point R-SG-AUX1 to component Granular B with Surface 

Feature Style set to Auxiliary and point Constraints set as: 

 

R-SG-AUX1 

 

 

18. Change point R-SG-GR Vector-Offset constrain to: 

 

 

 

The Vector-Offset constraint (Constraint 2) set as: 

 

 

 

19.  A partial rock shatter component need to be added to the template to 

capture the rock shatter quantities when the transition falls in between 

points R-SG-EP and R-SG-GR. 
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Right click in the template edit window, select Add New Component 

> Simple. Put the following information in the Current Component 

input fields. 

 

  

A new component RockShatterPart is added to the template with 

default point names. 

 

 

 

20. Move the top left point of the newly created component to the point L-

SH1 and merge with point L-SH1. Move the bottom left point of the 

newly created component to the point L-SH12 and merge with point 

L-SH12. 
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21. Rename top right point to R-SH-P1 and set the point Constraints as: 

 

R-SH-P1 

 

 

22. Rename bottom right point to R-SH-P2 and set the point Constraints 

as: 

 

R-SH-P2 
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23. Add display rule to the component. Double click on the component to 

open up the Component Properties dialog. Click Edit button on the 

right side of the Display Rules field. A new dialog – Component 

Display Conditional Expression dialog appears. Click Add button and 

add the following rule to the template: 

 

 

 

Create the conditional expression for RockShatterPart as shown 

below: 
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Click OK to return to Component Properties dialog. 

 

 

 

24. Click Apply then Close button to close the dialog. The component 

temporarily disappeared form the template.  

 

 

 

25. Save the template and close Create Template dialog. Open Roadway 

Designer. 

26. Select Corridor > Template Drops. The Template Drops dialog 

appears.  

a) On the dialog, verify that the current Corridor is Example1. 

b) Type 10+270 in the Station field and 10 in the Interval field. 

c) In the Library Templates window, double click on the active 

template library Example.itl, and then double click on the folder 

Example1.   

d) When the folder expanded, select template Transition from the 

library tree. 

e) Click Add button on the right side to add the selected template to 

the Current Template Drops list. 
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27. Add template Example1 Rock/Swamp at the end of the transition: 

a) Type 10+370 in the Station field and 10 in the Interval field. 

b) Select template Example1 Rock/Swamp from the library tree 

under Example1. 

c) Click Add button on the right side to add the selected template to 

the Current Template Drops list. 

 

 

 

28. Disable template transition by clicking on the X in the Enable 

Transition column in the Current Template Drops window. 

 

 

 

The column will show blank after the transitions have been removed 

between the templates. 
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29. Click Close button to dismiss the dialog and return to Roadway 

Designer. Select File > Save to save the corridor file with new 

template drops. 

30. Go through the cross sections between station 10+270 and station 

10+360.  

For transition from partial rock shatter to full rock shatter, the rock cut 

edge shift from left side of point R-SG-EP at station 10+270 to the 

right side of the point at 10+280.   
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For transition from full rock shatter to partial rock shatter, the rock cut 

edge shift from right side of point R-SG-EP at station 10+320 to the 

left side of the point at 10+360.   

 

 

 

 

 

31. Record the transition range then, select Tools > Parametric 

Constraints. On the Parametric Constraints dialog, add following 

entries: 

 

 

 

32. Click on Close to dismiss the dialog. In Roadway Designer, check the 

transition cross sections again. All the cross sections in the transition 

range now have granular B transformed from 150mm to 300mm. 
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33. Because of different depth of granular B, the full range rock shatter on 

the right side of R-SG-EP is showing up at station 10+280 now. 

 

 

 

To fix this cross section, select Corridor > End Condition 

Exceptions to open the End Condition Exceptions dialog. 
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34. In the Station Range field of the dialog, give Start station 10+280 and 

Stop station 10+281. Select Right Override option in the Apply To 

field.  

35. Click Add to create the end condition exception for the given station 

range. 

 

 

 

36. Click Edit button to open the template edit dialog. 

 

 



 

 
InRoads Typical Example 1 – Version 1.0                                                                         Page 130 

 

37. In the edit window, delete both R-Rock Cut and R-Rock Cut1 

components (in cyan). 

 

  

 

38. In the Template Library window on the left side of the dialog, expand 

the MTO Library folder. Find the end condition Earth Cut V Ditch 

under End Conditions. 

 

 

 

Drag and drop the selected end condition to point R-SG-GR. 
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39. Click OK to return to the End Condition Exceptions dialog. Click 

Close to return to Roadway Designer. 

 

  

 

40. The transition from rock to earth also involves rock fill as treatment 

within the depth of t (2m). To estimate the rock fill quantities, 

additional components need to be added to the template. Save and 

close the Roadway Designer.  

 

41. Open the Create Template dialog. Make the template Transition to be 

the active template. Right click in the template edit window, select 

Add New Component > Overlay/Stripping from the pop-up menu. 

42. A Current Component field appears below the template edit window. 

Create component RockEmbankment with information input as shown 

bellow: 

Note:  Rock fill will have different scenarios which include the fill 

depth is more or less than the treatment depth, the start point is on 

the left or the right side of subgrade crown point. 
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The RockEmbankment component will go through points L-SG2, R-

SG-EP1, R-SG-GR, R-BC, and with the last point R-RFB set as: 
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43. Right click in the template edit window and select Add New 

Component > Overlay/Stripping from the pop-up menu. Create 

component RockEmbankment1 with information input as shown 

bellow: 

 

 

 

The RockEmbankment1 component will go through points R-SG2, R-

SG-GR, R-BC, and point R-RFB. 

 

 

 

44. Right click in the template edit window and select Add New 

Component > Overlay/Stripping from the pop-up menu. Create 

component RockEmbankment2 with information input as shown 

bellow: 
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The RockEmbankment2 component will go through points L-SG2, R-

SG-EP1, R-SG-GR. 

 

 

 

45. Right click in the template edit window and select Add New 

Component > Simple from the pop-up menu to create a component 

RockEmbankment2-1 to the right of component RockEmbankment2. 

 

 

 

Modify component properties to make RockEmbankment2-1 to be 

child component of RockEmbankment2. 
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46. Move the top left point of component RockEmbankment2-1 to point 

R-SG-SG and merge with point R-SG-GR.  

47. Rename point 3 to R-RFB1 and set constraints as: 

 

R-RFB1 

  

 

48. Right click in the template edit window and select Add New 

Component > Null Point from the pop-up menu to create a null point 

R-RF and set constraints as: 

 

R-RF 

 

 

49. Rename point 2 to R-RFB2 and set constraints as: 

 

R-RFB2 

 

 

50. Rename point 1 to R-RFT and set constraints as: 
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R-RFT 

 

 

 

 

51. Set display rules for rock fill components. Double click on 

RockEmbankment component to open the Component Properties 

dialog. Click Edit button to the right of Display Rules field. Click Add 

button at the bottom of the Component Display Conditional 

Expression dialog. Add the following display rules to the template. 

 

Rule8 
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Rule9 

 

 

Rule10 

 

 

52. Create the conditional expression for RockEmbankment as shown 

below: 

 

 

 

Click Apply then Close.   
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53. Double click on RockEmbankment1 component to open the 

Component Properties dialog. Click Edit button to the right of Display 

Rules field.  

Create the conditional expression for RockEmbankment1 as shown 

below: 

 

 

 

Click Apply then Close. 

 

54. Double click on RockEmbankment2 component to open the 

Component Properties dialog. Click Edit button to the right of Display 

Rules field.  

Create the conditional expression for RockEmbankment2 as shown 

below: 
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Click Apply then Close. 

 

 

 

55. Save the template and close the Create Template dialog. 

56. Open the Roadway Designer dialog. Select Corridor > Template 

Drops. Select the template drops at 10+270 in the Current Template 

Drops list window, then click the Synchronize with Library button at 

the bottom left of the dialog. 
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57. Check the cross section in the rock transition area. Now cross sections 

are shown with rock fill treatment. 

  

 

 

 



 

 
InRoads Typical Example 1 – Version 1.0                                                                         Page 141 

 

 

58. Set end condition transition. Select Corridor > End Condition 

Exceptions to open the End Condition Exceptions dialog.  In the 

Station Range field of the dialog, give the Start station 10+170 and 

Stop station 10+180. Select Left Transition option in the Apply To 

field.  Click Add to create the end condition exception for the given 

station range. 

 

 

 

Click Edit button to open the Edit Transition dialog. 
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Create ditch transition from V ditch to flat bottom ditch as shown 

below. 

 

 

 

When finish, close all the dialogs and return to Roadway Designer. 
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59. When point R-RK-CHK goes beyond the roadway limits, additional 

controls need to be added to model the corridor properly. Select 

Corridor > Point Controls.  Add the following point control. 

 

 

 

60. Select Tools > Parametric Constraints. Add the following 

parametric constraints to the Roadway Designer: 

 

 

 

 

 

Close all dialogs and save the Roadway Designer file. 

 

7.7 Creating Finished Surfaces 
 

1. On the Roadway Designer dialog, select Corridor > Create Surface.  

2. On the Create Surface dialog, verify that only corridor Example1 is 

selected and all the options selected as shown below: 
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3. Click Apply. InRoads will process all the cross section in the selected 

corridor. A message window pops up to show the progress. 

 

  

 

4. When the process finish, click Close to dismiss the Create Surface 

dialog. 

5. Close Roadway Design. Save the changes when see following 

message. 
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6. Go to InRoads Explorer. In the left pane, check the Surfaces folder. 

Surface Example1 is listed under Surfaces. 

 

 

 

7.8 Creating Alternate Surfaces 
 

TA, TB and SG surfaces can be created as alternate surfaces by selecting 

each point on that surface and specifying the alternate surface name in the 

point properties window.  

 

1. Select Modeler > Create Template.  

2. On the Create Template dialog, select template Example1 

Rock/Swamp from Template Library. 

3. Double click on point L-TA-ER and type TA in the Alternate Surface 

field. Click Apply button. 

 

 

 

4. Repeat above process for points L-TA-AUX, L-TA-EP, TA-CL, R-TA-

EP, R-TA-AUX, and R-TA-ER. 

5. Give alternate surface name TB for points L-TB-GS, L-TB-AUX, L-TB-

EP, TB-CL, R-TB-EP, R-TB-AUX, and R-TB-GS. 

6. Give alternate surface name SG for points L-TS, L-TS1, L-TC, L-TC1, 

L-BC, L-TC2, L-BRK1, L-BRK, L-DO, L-DI, L-SG-GR, L-SG-AUX, L-
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SG-EP, SG-CL, R-SG-EP, R-SG-AUX, R-SG-GR, R-DI, R-DO, R-

BRK, R-BRK1, R-TC2, R-TC1, R-TC, R-BC, R-TS1,and R-TS. 

7. Select template Transition from Template Library. 

8. Give alternate surface name TA for points L-TA-ER, L-TA-AUX, L-TA-

EP, TA-CL, R-TA-EP, R-TA-AUX, and R-TA-ER. 

9. Give alternate surface name TB for points L-TB-GS, L-TB-AUX, L-TB-

EP, TB-CL, R-TB-EP, R-TB-AUX, and R-TB-GS. 

10. Give alternate surface name SG for points L-TS, L-TS1, L-TC, L-TC1, 

L-BC, L-TC2, L-BRK1, L-BRK, L-DO, L-DI, L-SG-GR, L-SG-AUX1, 

L-SG1, L-SG2, R-SG-EP1, R-SG1, R-SG2, R-SG-AUX1, R-SG-GR, R-

DI, R-DO, R-BRK, R-BRK1, R-TC2, R-TC1, R-TC, R-BC, R-TS1,and 

R-TS. 

11. Save template library and close the Create Template dialog.  

12. Select Modeler > Roadway Designer. 

13. Select Corridor > Templates Drops.  

14. Select all the template drops in red and click on the Synchronize with 

Library button. Close the dialog. 

15. Select Corridor > End Condition Exceptions.  

16. Select the LeftOverride from 10+080 to 10+160, click Edit. 

17. Select point L-MU-OG from the template edit window. 

 

 

 

18. Type SG in the Alternate Surface field. Click Apply button. 
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19. Close the dialog. Select the RightOverride from 10+280 to 10+281, 

click Edit. 

20. Give alternate surface name SG for points R-BC, R-TC1, and R-TC. 

Close all the dialogs and return to Roadway Desinger. 

21. Select Corridor > Create Surface. 

22. Check the Create Alternate Surfaces option on the Create Surface 

dialog. 

 

 

 

23. Click Apply. Save Roadway Designer and close the dialog. 

24. Go to InRoads Explorer. In the left pane, check the Surfaces folder. 

Alternate surfaces are created under Surfaces. 

 

 

 

25. Right click on surface Example1-SG and select Properties from the 

pop-up menu.  

26. Click on the Advanced tab on the Surface Properties dialog. Select 

DTM_SG from the Symbology drop-down list for both Cross Sections 

and Profiles. 
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27. Click Apply > Close. 

28. Repeat the process to set symbology DTM_TA for surface Example1-

TA. 

 

 

 

29. Set symbology DTM_TB for surface Example1-TB. 
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30. Save surfaces Example1, Example1-TA, Example1-TB, and 

Example1-SG. 

 

7.9 Updating Project File 
 

1. Go to InRoads main menu, select File > Save As. 

2. On the Save As dialog, verify the Save as type is Projects (*.rwk) and 

select Example1.rwk. 

3. Click the Options (…) button on the lower right corner of the Save As 

dialog box. The Project Options dialog box will appear. 

4. Click Surfaces tab, check Add for Example1, Example1-SG, 

Example1-TA, and Example1-TB surfaces. 

 

 

 

 

 

5. Click OK button to close the Project Options dialog box. 

6. Click the Save button and confirm to replace existing project file.  

7. Click Cancel to close the dialog. 

 

Note:  If the Update option is selected, the surface file(s) will be 

saved when you save the project. 
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8.0 Cross Section 
 

8.1 Creating Cross Sections 
 

1. Load MTO_InRoads_Template.dwg from project 

folder...\Example1\Standards. 

2. Click AutoCAD’s File > Save As command to save the drawing to 

project folder …\Example1\Drawings with name CrossSections. 

3. Set the Global Scale Factors to 0.1. 

4. Select Evaluation > Cross Section > Cross Sections. 

5. Click Preferences and load named preference MTO_Sheet(1:100). 

On the dialog of General leaf, change the interval to 10m. Select 

surface Ex1_OG, Rock, Swamp, and Example1 from the Surfaces list.  

 

 

 

6. Click Source and verify that the proper alignment is show in the 

alignment field. 
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7. Click Controls > Limits. Verify the Station range.  

 

 

 

8. Click Critical Sections under Controls. Select options. 

 

  

 

9. Click Apply and follow the prompt at AutoCAD command line to 

provide an insert point in the drawing.  

10. View the cross sections that have been created. 

 

Whole Sheet: 
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Swamp Treatment: 

 

 

Rock Treatment: 

 

 

 

8.2 Updating Cross Section 
 

1. Select Evaluation > Cross Section > Cross Sections. 

2. Click on the Update Cross Section folder on the left pane of Cross 

Sections dialog.  

3. Click on Crossing Features leaf. Toggle on the Display On option. 

4. Select surface Example1 from the Surface list. 

5. Turn on the Feature Filter Lock and select filter TP Surface Features, 

and then select all the features in the Feature list window. 
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6. Click Apply.  Top surface features points will display in the cross 

sections. 

7. Select surface Example1-SG from the Surface list. 

8. Turn off the Feature Filter Lock, and then select all the features except 

in the Feature list window (feature Exterior Boundary is greyed out 

and will not be selected). 
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9. Click Apply.  All the subgrade surface features points will display in 

the cross sections. 

10. Close the dialog and save the drawing. 

 

8.3 Annotating Cross Sections 
 

Surface or surface crossing features (if loaded) can be annotated in cross 

sections. Verify that the Global Scale Factors is set to 0.1.  

 

OG surface 

 

1. Select Evaluation > Cross Section > Cross Sections. 

2. Click on the Annotate Cross Section folder on the left pane of Cross 

Sections dialog.  

3. Click on Preferences and load named preference MTO_OG (1:100).  

4. Click on General leaf and select Ex1_OG surface. 

5. Click on Points leaf and check Include Points option. 

 

 

 

6. Click Apply. The OG surface is annotated in cross sections. 
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TP Surface.  

 

1. With the Cross Sections dialog open, click on Preferences and load 

named preference MTO_TP (1:100).  

2. Click on General leaf and select surface Example1. 

3. Click on Features leaf then click on Annotate. Select all the features 

from the features list.  

 

 

 

4. Click Apply. The top surface is annotated in cross sections. 

 

 

 

 

SG Surface.  

 

1. With the Cross Sections dialog open, click on Preferences and load 

named preference MTO_SG (1:100).  

2. Click on General leaf and unselect surface Example1 and select 

surface Eexample1_SG. 
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3. Click on Features leaf then click on Annotate. Select all the features 

from the features list. 

 

 

 

4. Click Apply. The subgrade surface is annotated in cross sections. 

 

 

 

5. Close the Cross Sections dialog and save the AutoCAD drawing. 
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9.0 Volumes and Mass Haul Diagram 
 

9.1 Calculating End-Area Volumes 
 

After creating cross section set, the End-Area Volumes can be used to 

perform the traditional end-area volume calculation to compute cut, fill, 

and net volumes. To compute the quantities of components, the 

components must be displayed in the cross section. 

  

InRoads calculates the exact end areas at each stations. The neat volumes 

area calculated between stations using the average end area method. The 

computed volumes can be adjusted for shrinkage or expansion.  

 

 

 

1. Verify that the cross section drawing created in previous section is the 

active drawing.  

2. Verify that the Global Scale Factors is set to 0.1. 

3. Select Evaluation > Cross Section > Cross Sections. 

4. Click on the End-Area Volumes folder on the left pane of Cross 

Sections dialog. 

5. Click on Preferences and load the named preference MTO.  

6. Click on Annotation. Check the default settings of the named 

Preference MTO.  Change the options as you need.  

 

Note:  The Compaction/Expansion factor and stripping depths used 

in this example are for demonstration only. For real projects, refer 

to Geotechnical Report or the Regional Geotechnical Section’s 

recommendation. 
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7. Click General. In the Surface list window, make sure all the surfaces 

including existing (Ex1_OG), designed (Example1), and substratum 

(Rock and Swamp) are checked. With the preference MTO, the volume 

will be calculated for whole cross section set and the Create XML 

Report option is toggled on. 
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8. Click Unsuitable Materials by Station. For new construction, assume 

stripping will be across the entire cross section. Also assume the 

stripping depths are 0.15m in cuts and 0.30 in fills. For swamp 

excavation area (10+080 to 10+160), stripping is not calculated. 

9. Add two stripping sections (10+000 to 10+080 and 10+160 to 10+500) 

to the list with the Style set to Stripping. Both stripping section have 

Cut Depth 0.15m and Fill Depth 0.30m.  

 

 

 

10. Click Classification. Use Cut/Fill Factor to account for any swell or 

shrinkage that may occur when remove/place material. Assume 15% 

increase for the computed earth fill quantity to compensate handing 

and compaction lose. Assume 50% expansion to rock cut excavation 

quantity for computing rock material available for fill. Edit the Cut/Fill 

factors in the Materials List table.  

As a component of the template, Rock Shatter doesn’t have option to 

give the Cut Factor. However, the Rock Shatter quantity is included in 

the rock excavation quantity and subject to the same expansion factor 

as Rock Cut. 
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11. Click Apply to calculate the volumes. InRoads will annotate the cross 

section set based on the selections on the Annotation leaf.  

 

 

 

12. With Create XML Report option toggled on, Bentley Civil Report 

Browser displayed. Select EndAreaVolume style sheet from the 

Evaluation folder in the left pane of the dialog. 
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13. The template used for this example has swamp related components to 

calculate swamp excavation and backfill. In the swamp area, the 

normal cut volume also includes swamp excavation volume which is 

duplicated and should be removed from the calculation. Record the cut 

volume in the volume report within the swamp area as shown above.  

14. Return to Cross Sections dialog. Click on Added Quantities. Add the 

cut volume (negative for deduction) as recorded in last step for each 

station within the swamp area to the Added Quantities list. 

 

 

 

15. Click Apply to calculate the volume. In the Bentley Civil Report 

Browser, select EndAreaVolume style sheet to view the results. The 
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swamp excavation volume is now added as negative amount to the 

normal cut quantities. 

 

 

 

16. Select Volumes style sheet and go to the end of the report. A summary 

table of total volumes of each material is generated by InRoads. There 

are 4 columns in the table. From left to right they are Material 

(component) Name, Volume, Adjusted Volume, and if the material is 

included in the Mass Ordinate. 

 

 

 

17. Based on the template and the input during quantity calculation, the 

quantity of: 

a. Earth Cut  = Normal Cut + Added Cut (see step 15) 

  = 12967.63 + (-1339.54) 

  =11628.09 m3 
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b. Rock Excavation (include Rock Cut and Rock Shatter): 

  = Rock (from InRoads) 

  = 1381.68 

 

c. Available Materials from Rock Excavation will be: 

  = Rock expanded – Rock Shatter left in place 

  = 1381.68 X 1.5 – 425 

  = 2072.52 – 425 

  = 1647.52 

d. Muskeg Excavation is the Excavated Swamp Material volume. 

e. Muskeg Backfill is the volume of embankment with specified 

material between the bottom of swamp excavation and the OG 

surface. 

f. Fill is the volume of embankment with Earth Fill between the 

OG surface and the bottom of Granular B. 

g. Muskeg is the volume for the area to be backfilled with swamp 

material (the area from the edge of the backfill embankment to 

the excavation limits). 

 

h. Rock Embankment is the volume of rock fill treatment in the 

transition area. 

 

i. Granular B is the volume of granular sub-base calculated from 

End-Area. The volume doesn’t include the expected loss in the 

area where granular sub-base is placed on rock subgrade. Refer 

to CDED manual for the application of the compensating factor. 

 

18. Save the drawing with a different name (Cross section with end-area 

quantities). 

 

Note:  The Rock Cut is assumed 50% expansion and the 

Rock Shatter is subject to the same expansion factor as Rock 

Cut. Since the Shatter is left in place, the Available Material 

from Rock Shatter consists the expanded portion only. 

Note:  Refer to Rock Treatment in Section 7.6 for details. 

Note:  Refer to Components Over Swamp in Section 6.2 for 

details. 
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9.2 Generating Mass-Haul Diagram 
 

InRoads uses the End-Area Volume to generate the Mass-Haul diagram 

that shows cumulative total of cut and fill volumes along a horizontal 

alignment.  

 

1. Close the report browser and return to the Cross Sections dialog. 

2. Click Classification. In the Materials List table, include the Fill and 

Rock Shatter to the Mass Ordinate. Assume 15% increase for the 

computed Fill (earth) quantity.  

 

 

 

3. Click on Mass-Haul Diagram folder. 

4. Change the Global Scale Factors to 1. 

5. Click on Preferences and load the named preference 

MTO_MassHaul_1000 (1000 m
3
 per major grid). 

6. Click Apply. 

7. In AutoCAD, provide an insert point for the Mass Hall Diagram.  

8. The Mass Hall Diagram will be drawn with the preset exaggeration. 
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9. Save the drawing as a Mass Haul Diagram. 
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10.0 Reports and Data Exchange 
 

10.1   End-Area Volume Report 
 

The End-Area Volume Report is generated with End-Area Volumes 

command. Refer to Section 9.1 for details about end-area volume 

calculation and report generation. Once the report is generated by InRoads 

and the Bentley Civil Report Browser is displayed, a few style sheets from 

the Evaluation folder can be used to view End-Area Volume. 

 

 

 

10.2   Cross Section Reports 
 

Cross Section Report command is used to create station, offset, and 

elevation report for a specified cross section set. All surfaces, features, and 

components that you want in the report must be displayed in the cross 

section set. 

 

10.2.1 Top of Pavement Report 

 

The InRoads generated design surface can be used for Top of Pavement 

report. 

 

1. Open the saved cross section drawing (or you can generate a new set). 

2. Select Evaluation > Cross Section > Cross Section Report.  

3. On the Cross Section Report dialog, verify the Cross Section Set is 

Example1. 

4. Select surface Example1 (design surface) from the Include Surfaces 

list. 
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5. Click Apply. 

6. In the Bentley Civil Report Browser, select Evaluation > 

CrossSectionStakingTable.xsl.  

 

 

 

7. Save the report then close the Bentley Civil Report Browser. 

 

10.2.2 TA, TB Report 

 

1. Select Evaluation > Cross Section > Cross Sections. 
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2. Click on the Update Cross Section folder on the left pane of Cross 

Sections dialog. 

3. Click on Surfaces. Toggle on the Display On option. 

4. Select surface Example1-TA from the Surface list. Click Apply. 

5. Select surface Example1-TB from the Surface list. Click Apply. 

6. Toggle on the Display Off option to make sure TA and TB surfaces 

have been added to the cross section set. 

 

 

 

7. Close Cross Sections dialog. 

8. Select Evaluation > Cross Section > Cross Section Report. 

9. On the Cross Section Report dialog, verify the Cross Section Set is 

Example1. 

10. Select surface Example1-TA from the Include Surfaces list. 

 

 

 

11. Click Apply. 
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12. In the Bentley Civil Report Browser, select Evaluation > 

CrossSectionGradeBookWide.xsl. 

 

 

 

13. Save the report then close the Bentley Civil Report Browser. 

14. On the Cross Section Report dialog, select surface Example1-TB from 

the Include Surfaces list. 

15. Click Apply. 

16. In the Bentley Civil Report Browser, select Evaluation > 

CrossSectionGradeBookWide.xsl. 
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17. Save the report then close the Bentley Civil Report Browser. 

18. Close the Cross Section Report dialog. 

 

10.2.3 Subgrade Report 

 

1. Repeat steps 1 to 7 in section 10.2.2 to add surface Example1-TB to 

the cross section set. 

2. Select Evaluation > Cross Section > Cross Section Report. 

3. On the Cross Section Report dialog, verify the Cross Section Set is 

Example1. 

4. Select surface Example1-TA from the Include Surfaces list. 

5. Click Apply. 

6. In the Bentley Civil Report Browser, select Evaluation > 

CrossSectionGradeBookWide.xsl. 

 

 

 

7. Save the report then close the Bentley Civil Report Browser. 

8. Close the Cross Section Report dialog. 

 

10.2.4 Rock Face Report 

 

1. Select Tools > XML Reports > Station Offset. 

2. On Station Offset Report dialog, select General leaf. 

3. Verify the Horizontal Alignment is Example1. 
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4. Select Include leaf. Toggle on the On-Alignment option in the 

Horizontal Points field. 

 

 

 

5. Select Features leaf. 

6. Select design surface Example1 for reporting from the Surface drop-

down list.  

7. In the available Features list window, select feature L-BRK (the top of 

rock face) and L-DO (the bottom of rock face). These two features are 

used to report left side rock face. 
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8. Click Apply. 

9. In the Bentley Civil Report Browser, select StationOffset > 

VerticalFace.xsl. 

 

 

 

10. Left side has two rock face sections from 10+180 to 10+200 and from 

10+270 to 10+370. The area value between 10+200 and 10+270 

should be removed from the report. Right click on the report and select 

Export to Microsoft Excel form the pop-up menu. 
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11. In Excel, type 0 in the area field at station 10+270 (start location for 

the second part of rock face). 

12. Sum the area column for the total area of rock face on the left side. 

 

 

 

13. Save the report and close Excel. 
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14. Return to the Station Offset Report dialog. Select Features leaf. In the 

available Features list window, select feature R-BRK (the top of rock 

face) and R-DO (the bottom of rock face). These two features are used 

to report right side rock face. 

15. Click Apply. 

16. In the Bentley Civil Report Browser, select StationOffset > 

VerticalFace.xsl. 

 

 

 

17. Save and close the report. Close the Station Offset Report dialog. 

 

10.3   Exporting Data 
 

Once design is completed, the intelligent design data can be exported to 

contractor for construction. InRoads uses the XML industry-standard 

format for data exchange and outputs standard formats for Trimble and 

Leica for machine-controlled grading and machine guidance. Refer to the 

document Exporting InRoads Data for Construction located at 

...\Program Files\Bentley\InRoads Group V8.11\...  for details. 

 
 

 

 

 

 


