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1.0 Overview  
 

This typical example illustrates the process for using Power InRoads in the design of an urban 

and rural undivided highway new construction/resurfacing project. The project presented in this 

example is for demonstration only. The example doesn’t reflect the whole range of InRoads 

capabilities and there are different ways for doing things in InRoads. The work flow may need to 

be modified from project to project to reflect different conditions and requirements. 

 

For easy identification, the directory, folder and file names are in italics in this document. 

 

In this example, all the InRoads commands are accessed from the InRoads Explorer menu bar. 

 

Project Type 

Urban and rural undivided highway new construction.  

 

Prerequisites 

Drafting: 

- Basic View Control & Editing Command in MicroStation Environment 

InRoads: 

User should be familiar with InRoads: 

- Working Environment 

- Tools 

- Surfaces 

- Features 

- Geometry 

- Template 

- Roadway Designer 

- Reports 

 

It is also recommended that the user be familiar with the following: 

- MTO InRoads Project Template 

- MTO Customization Documentation 

- MTO InRoads Standards and Preferences Manual – Power InRoads V8i(SS2) 

Highway Design: 

- Design principles 

- MTO Design Manuals, Guidelines, and Policies 
 

Software Version  

- Power InRoads V8i (SELECTseries 2) – Version 08.11.07.615 
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Design Data and InRoads Files 

The design data used in this example project is for demonstration only. Actual projects may vary.  

 

The length of this example project is 500m. 

 

 

Proposed Design 

 Rural Resurfacing 

From station 11+000 to 11+100, the following typical is to be used: 

 

 

Pavement: 

40mm Asphalt Top Course 

50mm Asphalt Base Course 

50mm (max.) Partial Depth Pavement Removal 

 

 Urban New Construction 

From station 11+100 to 12+300, the following typical is to be used: 
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From station 12+300 to 12+500, the following typical is to be used: 

 

 

 

Pavement: 

40mm Asphalt Top Course 

50mm Asphalt Base Course 

150mm Granular A 

300mm Granular B 

 

Partially Paved Shoulder: 

80mm Asphalt Surface Course 

 

Concrete Curb and Gutter 

From station 11+100 to 12+300: 

OPSD 600.010 (Barrier Curb 600mm) 

From station 12+300 to 12+500: 

OPSD 600.030 (Mountable Curb 800mm) 

 

The files listed and described below are provided in the Example 3 data set Data3.zip:  

Existing Ground Surface (.dtm) 

 ……\Data3.zip\Surfaces\Ex3_OG.dtm 

 

Geometry File (.alg) 

 ……\ Data3.zip\Geometry\Ex3.alg 

 

AutoCAD Drawings (.dwg) 

 ……\Data3.zip\Standards\MTO_InRoads_Template_SS2.dwg 
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Inroads Template Library (.itl) 

 ……\Data3.zip\Standards\MTO_STD_Templates.itl 

 

MTO Preference File (.xin) 

 ……\ Data3.zip\Standards\MTO_civil_SS2.xin 

 

Project Configuration File (.pcf) 

 ……\ Data3.zip\Standards\pcf\PROJECTNAME.pcf 

 

The following files will be created for the project design: 

Projects (.rwk) 

Roadway Design (.ird) 

Design Surfaces (.dtm) 

Reports (XML Data, .xml) 

Design Drawings (Plan, Profile, Cross Section, .dwg) 

 

Topics Covered: 

- Setting up Power InRoads Workspace  

- Setting up InRoads Project  

- Viewing Surface 

- Reviewing and Annotating Horizontal Alignment 

- Creating Existing Ground Profile 

- Reviewing and Annotating Vertical Alignment 

- Defining Typical Section 

- Modeling Roadway 

- Applying End Condition Exceptions  

- Creating Design Surfaces and Cross Sections 

- Performing Quantity Computations  

- Generating Design Drawings 

- Producing InRoads Reports 



 

 
InRoads Typical Example 3 – Version 1.0                                                                         Page 5 

2.0 InRoads Project Setup 
 

Note: All InRoads data files shall be as per the MTO InRoads Project directory structure 

posted on the MTO web site:  http://www.xfer.mto.gov.on.ca/PTASapps/index.htm 

 

This directory structure is mandatory for all in-house and service provider design work 

done with InRoads. 

 

This section describes how to set-up the Power InRoads workspace and InRoads project 

directory and file structure. 

 

2.1 Project Directory Set-up 
 

Getting started 

 

1. For this example, on your C drive create a project folder named 

InRoads Projects and then a folder named Example3. 

 

The folder path should now be:  C:\InRoads Projects\Example3. 

 

2. Go to the web site:  

http://www.xfer.mto.gov.on.ca/PTASapps/index.htm 

Click on InRoads under Menu on the left side of the page. A list of 

InRoads files will be shown on the right side of the page.  Click on the 

file Power InRoads V8i(SS2)PreferenceManual.zip and save it to the 

folder called InRoads Projects that you created in step 1.  Click Close. 

3. Extract the downloaded .zip file to the current folder. Double clicking 

on the file InRoads Project Template_SS2.exe to run the file. By 

default, the Unzip to folder is pointing to the current folder InRoads 

Projects. Use the Browse button to find the Example3 folder or you 

can type in \Example3 after the default folder. 

Note:  For all InRoads design work, put in the project GWP/WP 

folder a subfolder called InRoads or something similar.  This is where 

the InRoads highway design files should be kept. 
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4. Click Unzip button.  A folder called InRoads will be created in the 

Example3 folder if it does not exist and all subfolders will be 

automatically set-up. When it is finished, close the WinZip dialog. 

5. The folder Example3 will now look like this: 

 

 

 

6. The InRoads folder in the Example3 contains the following subfolders: 
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7. Copy Example 3 data set Data3.zip to the folder Example3. Right click 

on the compressed file Data3.zip and select Extract All from the pop-

up menu. 

 

  

 

8. Follow the Extraction Wizard. When the target directory appears on 

the dialog, make sure the path is pointed to the folder: 

…\Example3\InRoads. 

 

 

 

9. When finish, go through each folder to verify that files are installed 

properly as described under sample data set section in Section 1. 

10. Locate the Project Configuration File (*.pcf) in the following folder: 

 ……\InRoads\Standards\pcf 

11. Copy the file PORJECTNAME.pcf to the folder C:\InRoads Projects 

and rename it to Example3.pcf.  

12. Start Power InRoads V8i (SELECTseries 2). On the File Open dialog 

of Power InRoads, locate the User list field at the bottom right of the 

dialog. 
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13. If you haven’t created a user configuration file pointing to the project 

configuration file folder C:\InRoads Projects, click in the User field 

and select New from the list. If you have done so, select the user 

configuration file on the list, then click the Project field, the project 

configuration file Example3.pcf will be shown on the project list.  

14. To create user configuration, select New from the User list, Create 

User Configuration dialog pops up. Type a name in the Name field on 

the dialog. 

 

 

 

15. Click OK. Create User Configuration File dialog appears, type 

description in the Description field and click the Select button on the 

right side of the Project field. 
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16. Browse to the project configuration file folder C:\InRoads Projects\.  

Select the project configuration file Example3.pcf and click Open. 

17. When return to the Create User Configuration File dialog, the project 

configuration file you selected appears in the Project field. Click OK 

to close the dialog.  

18. When return to the File Open dialog, you can also select a customized 

user interface or leave it with the default user interface. 

 

 

 

19. Open MTO_InRoads_Template_SS2.dwg from the folder 

...\Example3\\InRoads\Standards. 

20. Verify that the value of the MicroStation configuration variable 

MS_DWGSAVEAPPLICATIONDATA is set to 1. Refer to MTO 

InRoads Standards and Preferences Manual Power InRoads 

V8i(SELECTseries 2) for details. 

21. Click File > Save As from MicroStation main menu bar to save the 

drawing to folder …\Example3\InRoads\Drawings and name it as 

Ex3.dwg. 

 

 

Note:  MTO_InRoads_Template_SS2.dwg file contains proper layers 

and is set up for using MTO InRoads preference file as described in 

MTO InRoads Standards and Preference Manual (V8i_SS2). 
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2.2 Project Defaults 
 

By setting up the project defaults, the user can set the default directory 

locations for opening/saving files for project design. The InRoads Project 

Defaults command is used to set up default directories for all file types 

that can be accessed through the File/Open and File/Save As dialog boxes. 

These include Project (.rwk), Surface (.dtm), Geometry (.alg), Template 

Library (.itl), and Roadway Design (.ird). All other files, which are opened 

or saved throughout the program, use the Project Default Directory setting. 

The project default file directories are stored in the computer’s registry.  

 

1. Click to File > Project Defaults on the InRoads Main Menu. 

2. Click on the New button and the New Configuration dialog box will 

appear. 

3. Type in Example3 in the Name field, click OK to save and close the 

dialog box. 

 

 

 

4. Click in the Preferences (*.xin) field and click the Browse button. The 

Open dialog will appear. Browse to …\Example3\\InRoads\Standards 

folder.  

5. Select MTO_civil_SS2.xin, and click Open, 

6. Click in the Project Default Directory field and click the Browse 

button. The Open dialog will appear. Browse to …\Example3|InRoads, 

and Click Open. 

7. Click in the Report Directory field and click the Browse button. The 

Open dialog will appear. Browse to …\Example3\InRoads\Reports, 

and Click Open. 

8. Click in the Projects (*.rwk) field and click the Browse button. The 

Open dialog will appear. Browse to …\Example3\InRoads, and Click 

Open. 

9. Click in the Surfaces (*.dtm) field and click the Browse button. The 

Open dialog will appear. Browse to …\Example3\InRoads\Surfaces, 

and Click Open. 

10. Click in the Geometry Projects (*.alg) field and click the Browse 

button. The Open dialog will appear. Browse to 

…\Example3\InRoads\Geometry, and Click Open. 
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11. Click in the Template Libraries (*.itl) field and click the Browse 

button. The Open dialog will appear. Browse to 

…\Example3\InRoads\Standards, and Click Open. 

12. Click in the Roadway Design (*.ird) field and click the Browse button. 

The Open dialog will appear. Browse to 

…\Example3\InRoads\Corridors, and Click Open. 

13. Click the Apply button to save the configuration, and then click the 

Close button. 

 

 

 

2.3 Project Files 
 

InRoads allows users to create a project file for each project. With project 

file, the user can quickly load all files needed for a particular project. A 

project file is composed of a list of files with path names. To create a 

project file for example 3: 
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1. Click to File > Open on the InRoads Main Menu.  

2. Change the Files of type to Surfaces (*.dtm) and select Ex3_OG.dtm. 

Click Open. 

 

 

3. Change the Files of type to Geometry Projects (*.alg) and select 

Ex3.alg. Click Open. 

4. Change the Files of type to Template Libraries (*.itl) and select 

MTO_STD_Templates. Click Open and then Cancel. 

5. Create Project file (.rwk). Click to File > Save > Project on the 

InRoads Main Menu.  

6. On the lower right corner of the Save As dialog box, click the Options 

(…) button. The Project Options dialog box will appear.  

 

 

 

7. For Surfaces tab, check Add for the Existing surface Ex3_OG that was 

loaded in step 2. 

 

8. For the Geometry Project tab, check Add for the geometry project Ex3 

that was loaded in step 3. 

Note:  Proposed surfaces will be created in the design process. 

These files will be checked with both Add and Update options. 

Note:  After selecting the file type, the path will change to the 

folder as defined in the Project Defaults. 
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9. For the XIN Preferences and Template Library tabs, check Add and 

Update on each file listed under the File Name. 

10. Click OK button to close the Project Options dialog box. 

11. In the Save As dialog box click in the File name field and type in 

Example3. Click the Save to complete creating the project file. Click 

Cancel to close the dialog. 

 

 

 

 

 

 

 

 

Note:  Project files must be maintained and updated through the 

project design process. After running Roadway Designer and creating 

proposed surfaces, the surfaces (.dtm) and Roadway Design (.ird) will 

be added to the .rwk. 
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3.0 Existing Conditions 
 

3.1 Viewing Original Ground (OG) Surface 
 

Viewing OG surface 

 

InRoads provides users several viewing tools to display the surface data 

including the perimeter, triangles, contours and features. 

1. Turn off the Style lock and select Pencil mode on the Locks toolbar. 

 

2. Select Surface > View Surface > Perimeter.  

 

 

 

3. Click on the Preferences button. Make sure the preference MTO is 

selected. Close the Preference dialog. 

4. Select the Surface Ex3_OG from the drop-down list. 

5. Click on the Apply button and the perimeter is drawn in MicroStation.  

6. Click Close to close the View Perimeter dialog. 

7. In McroStation View 1 window, click on the Fit View icon from the 

view controls tool bar. Now you can see the perimeter in the model. 

 

Note:  If the Style lock is on, the dialog box will not appear when 

you choose one of the View Surface commands. 
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8. Select File > Save Settings form MicroStation main menu bar or using 

Ctrl +F keys to save current view settings. 

9. Select File > Save form MicroStation main menu bar or using Ctrl +S 

keys to save the changes. 

10. Select Surface > View Surface > Triangles. 

 

 

 

11. Click on the Preferences button. Make sure the preference MTO is 

selected. Close the Preference dialog. 

12. Select the Surface Ex3_OG from the drop-down list. 

13. Click on the Apply button and the triangles are drawn in MicroStation. 
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14. Click Close. 

15. Active MicroStation Element Selection tool and select the perimeter 

and triangles, and then select the Delete Element tool to delete. 

 

 

 

 

 

 

 

16. Select Surface > View Surface > Contours.  
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17. Click on the Preferences button. Select and load the preference MTO.  

Close the Preference dialog. 

18. Select the Surface Ex3_OG from the drop-down list. 

19. Click on the Apply button and the contours are drawn in MicroStation. 

 

 

 

20. Click Close. 

21. Delete the contours in MicroStation. 

22. Select Surface > View Surface > Features. 

23. On View Features dialog, select the Surface Ex3_OG from the drop-

down list. 

24. Select all EP/ES features from the Features list. 
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25. Click Apply then Close. 

26. Selected EP/ES features are drawn with given styles in MicroStation. 

 

 

 

3.2  Viewing OG Surface in Cross Sections 
 

The original ground surface can be viewed in cross sections along the 

given alignment (Ex3.alg). 

 

1. Make sure the geometry project Ex3.alg is loaded and is the active 

geometry project. 

2. Select Evaluation > Cross Section > Cross Sections.  

3. Click Preferences button.  

4. If the Active Preference is not MTO, load it. Click Close. 

5. Select General leaf. Set interval to 20 and check surface Ex3_OG in 

the Surfaces list. 



 

 
InRoads Typical Example 3 – Version 1.0                                                                         Page 19 

6. Select Source leaf. Make sure alignment Ex3 is selected. 

7. Click Apply and select an insert point in MicroStation. 

 

 

 

3.3 Generating Cross Section Reports 
 

After generate the cross section set, the Cross Section Report command 

can be used to create station, offset, and elevation report. 

 

1. Select Evaluation > Cross Section > Cross Section Report. 

2. On the Cross Section Report dialog, select Cross Section Set EX3. 

3. Select Ex3_OG from the Include Surfaces list. 

 

 

 

4. Click on Apply. 

5. In the Bentley Civil Report Browser, select 

CrossSectionGradbookWide.xsl under Evaluation. The surface is 

reported in Station, Elevation, and Offset format. 
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3.4 Check Existing Pavement Width 
 

In this section, InRoads XML report is used to report existing pavement 

width. The information can be used to analyse the existing pavement 

condition and then used for creating the project templates. 

 

1. Select Tools > XML Reports > Station Base. 

2. On the Station Base Report dialog, select General leaf.  

3. Select Horizontal Alignment option from the From field and select 

Ex3 from the drop-down list as the reporting alignment.  

 

 

Note:  For multiple surfaces, you can report each surface separately 

or select all the surfaces and report them in one single report. 
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4. Select Include leaf, toggle on Interval option and set to 25. 

 

 

 

5. Select Features leaf. On the dialog, select Ex3_OG from the Surface 

list then select LEP and REP from the Features list.  

 

 

 

6. Click Apply. In the Bentley Civil Report Browser, select 

StationOffset > StationOffset.xsl. 

 

 

 

7.  Save the report. 
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4.0 Horizontal Alignment 
 

A geometry project Ex3.alg is provided with the sample data set. It 

contains a horizontal alignment Ex3 and a vertical alignment with the 

same name Ex3.  

 

4.1 Viewing the Active Horizontal Alignment 
 

1. Delete the graphics in MicroStation. 

2. Select Geometry > View Geometry > Active Horizontal. Horizontal 

alignment is displayed in MicroStation with the assigned style. 

 

 

 

4.2 Stationing 
 

A chainage equation is included in this example. 

1. To add, modify or review chainage equation, select Geometry > 

Horizontal Curve Set > Stationing.  

2. At the bottom portion of the Stationing dialog is the Station Equations 

list. The following  station equation is included in the project: 

11+250 = a 12+250 

 

Note:  When entering the ahead station, you must specify a name for 

the station equation. An alpha character must be included in the ahead 

station to differentiate the ahead station from the back station. 
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3. Click Report.  InRoads generates the following results: 

 

 

 

4. Close all the dialogs. 

 

4.3 Reviewing Horizontal Alignments 
 

The Review Horizontal Alignment command is used to review a selected 

geometry in detail.   

 

1. Select Geometry > Review Horizontal.  

2. On the Review Horizontal Alignment dialog, there are three different 

modes can be selected in the Mode section to display different 
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information. Shown below are the Review Horizontal Alignment 

dialogs with the Alignment and Element mode selected. The review 

information can be displayed in MicroStation using the Display button 

or saved as an ASCII file using the Save As button, and be used to 

recreate the horizontal alignment. 

 

 

 

 

 

4.4 Displaying Stationing 
 

The View Stationing command is used to place station annotation text 

along the active horizontal alignment at a specified interval. 

 

1. Select Geometry > View Geometry > Stationing. 

2. Click on the Preferences button. Select and load the named preference 

MTO_Alignment_P&D.  Close the Preference dialog. 

3. Click Apply and then Close. 

4. Stationing will be generated on the Planning and Design layer as 

defined in MTO AutoCAD Standards Guide. 
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4.5 Annotating Horizontal Alignments 
 

Horizontal Annotation command is used to display and annotate 

horizontal alignments, points, and elements.  

 

1. Select Geometry > View Geometry > Horizontal Annotation 

2. Click Preferences button.  

3. On Preferences dialog, select MTO_Alignment_P&D, click Load > 

Close. 

4. Click in the Horizontal Alignments Include field. 

5. Click Filter button. 

6. On the Geometry Selection Filter dialog, select alignment Ex3 from 

the Available side. 

7. Click Add button to put the alignment on the Selected side. 

8. Click OK to return to the View Horizontal Annotation dialog. 

9. Click Apply. The selected alignment is displayed with element data. 
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10. Click Close. 

 

4.6 Generating Horizontal Alignment Report 
 

The Review Horizontal command can be used to report detailed 

information about the elements in selected horizontal alignment. The 

information can be displayed in MicroStation or saved to an ASCII file.  

Select different Mode to report different parts of the alignment. 

 

1. Select Geometry > Review Horizontal. 

2. Select Ex3 for Geometry Project and Ex3 for Horizontal Alignment. 

3. Select Mode to review and report information in different format. 
 

 

 

Horizontal Alignment Report also can be generated by InRoads XML 

Reports command and used with a large number of style sheets. 

 

1. Select Tools >XML Reports >Geometry. 

2. On the Geometry Report dialog, type Ex3 in the Horizontal 

Alignments Include field.  

3. Press Tab on the keyboard. The alignment Ex3 is listed on the 

Selected list. 

 

 

Note:  Filter or select button   also can be used to select 

alignments. Use * will select all the alignments in the geometry 

project.  
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4. Click Apply to create the report. Bentley Civil Report Browser is 

displayed. 

5. Select HorizontalAlignmentReview style sheet. 

 

 

 

6. Select Tools > Format Options in the Bentley Civil Report Browser. 

7. Make the desired changes to the format of the generated report. 

8. Select File > Save As in the Bentley Civil Report Browser to save the 

data into file with selected file type. 
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5.0 Profile and Vertical Alignment 
 

5.1 Extracting OG Profile 
 

1. Select Evaluation > Profile > Create Profile and the Create Profile 

dialog will appear. 

2. Click on Preferences button. Select and load named preference MTO. 

3. Close the Preference dialog. 

4. Click on the Source leaf. The Create field should be Window and 

Data.  

5. Check and make sure the Alignment is Ex3. 

 

 

 

6. Click on General leaf. By default, the Set Name is set to the active 

horizontal alignment Ex3.  

7. Make sure surface Ex3_OG is checked in the Surfaces list. 

 

 

 

8. Click on Controls leaf. Make sure the Elevation range and Station 

range are not used. 

9. Click Apply and select an insertion point in MicroStation. 
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5.2 Viewing Vertical Alignment 
 

The Active Vertical command is use to display the active vertical 

alignment without annotation. The geometry style associated with the 

alignment when they are created will be used for displaying. 

 

Select Geometry > View Geometry > Active Vertical. 

 

 
 

5.3 Reviewing Vertical Alignment 
 

Review Vertical Alignment command can be used to display information 

about the geometry of the active vertical alignment. The vertical alignment 

review information can be displayed in MicroStation or saved as an ASCII 

file. 

 

1. Select Geometry > Review Vertical. 
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2. In the Mode section, select Element. 

 

 

 

 

 

5.4 Annotating Vertical Alignment 
 

Use the Vertical Annotation command for more detailed annotation and 

display. Predefined preference is used to display the alignment points, 

tangent lines and vertical curves, and annotate the geometry. 

Note:  The active element is highlighted in the profile window. 
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1. Select Geometry > View Geometry > Vertical Annotation. 

2. Make sure both the Horizontal Alignment and Vertical Alignment are 

Ex3. 

3. Click Preferences.  

4. Select named preference MTO_Proposed and Load it. 

5. Close Preferences dialog 

6. Click Apply. 

 

 

 

7. Use MicroStation view controls to zoom in and view annotation. 

8. Close the View Vertical Annotation dialog box. 

 

5.5 Generating Vertical Alignment Report 
 

The Review Vertical command can be used to report detailed information 

about the geometry of the active vertical alignment. The information can 

be displayed in MicroStation or saved to an ASCII file. Select different 

Mode to review alignment or element information. 

 

1. Select Geometry > Review Vertical. 

2. Select Ex3 for Geometry Project, Ex3 for Horizontal Alignment and 

Ex3 for Vertical Alignment. 

3. Select Mode to review and report information in different format. 

 

 

 

Vertical Alignment Report also can be generated by InRoads XML 

Reports command and used with a large number of style sheets. 
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1. Select Tools >XML Reports >Geometry. 

2. On the Geometry Report dialog, type Ex3 in the Horizontal 

Alignments Include field. 

3. Press Tab on the keyboard. The alignment Ex3 is listed on the 

Selected list. 

4. Check the Include Vertical Alignments section. 

5. Toggle on the Active option. 

 

 

 

6. Click Apply. Bentley Civil Report Browser is displayed. 

7. Select VerticalAlignmentReview style sheet. 
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8. Select Tools > Format Options in the Bentley Civil Report Browser. 

9. Make the desired changes to the format of the generated report. 

10. Select File > Save As in the Bentley Civil Report Browser to save the 

data into file with selected file type. 
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6.0 Typical Sections 
 

6.1 Setting Up Project Template Library 
 

MTO standard template library contains predefined typical sections, 

components, and a point name list that point names are associated with 

MTO standard styles. This template library can be used as a start point to 

create project specific template library. 

 

1. Select File > Save As. 

2. On the Save As dialog, Change the Save as type to Template Libraries 

(*.itl). 

3. In the File name field, type in Example3. 

4. Click Save. A new template library Example3 is saved to the proper 

project folder as defined in project default. 

 

 

 

5. On the Save As dialog, Change the Save as type to Projects (*.rwk). 

6. Select Example3.rwk from the file list. Example3.rwk will appear in 

the File name field. 
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7. Click Options then select Template Library tab. 

8. On Project Options dialog, check both Add and Update options for 

template library Example3. 

 

 

 

9. Click OK to close the Project Options dialog. 

10. Click Save then Yes to confirm replace the existing project file. 

11. Click Cancel to close the Save As dialog. 

12. Select Modeler > Create Template. The Create Template dialog will 

appear. 

13. Select File > New > Folder. 

14. Type in Example3 for the name of the new folder in the Template 

Library window. 

 

 

 

15. Double click on MTO Library > Complete Templates > Inner & 

Outer Lane. 

16. Select template Type 1. 
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17. Select Edit > Copy. 

18. Select folder Example3.  

19. Select Edit > Paste. 

20. Double click folder Example3. The standard template is copied to 

folder Example3. 

 

 

 

21. Click File > Save. 

 

 

Note:  Project specific templates should be created/copied and 

modified in the project specific folder. 
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6.2 Creating Example 3 Templates 
 

In previous section, a template is selected from MTO Library folder and 

copied to the project template folder. This template is going to be 

modified to use in this example for rural section resurfacing.  

 

Rural Resurfacing Template 

 

The following typical is used to create rural resurfacing template: 

 

 

 

The assumptions made below are for this example only. 

 

a) Existing pavement asphalt to be partially removed up to 50mm. 

b) New pavement asphalt to be 40mm top course and 50mm base course. 

 

1. Review the Station Offset report generated in section 3.4. For 

resurfacing section from 11+000 to 11+100, the new pavement edges 

match the existing pavement edges. Milling and padding will be from 

left EP to right EP.   

2. Select the new copied template Type 1 in the Example3 folder.  

3. Select Edit > Rename. 

 

 

 

4. Type in a new name: Example3 Resurfacing. 

5. Provide additional information in the Description field in the Current 

Template section. 
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6. Click File > Save. 

 

7. Delete all rock related components since no rock is present in this 

project. In the template display window, find and right click on 

component L-Rock Shatter, select Delete Component from the pop-

up menu. 

 

  

 

8. Find and delete component L-Rock Cut, L-Rock Cut1, R-Rock 

Shatter, R-Rock Cut, and R-Rock Cut1.  

9. Right click on Granular B component, select Delete Component 

from the pop-up menu. 

 

Note:  During the process of customize the project template, save 

the template library when the modification is worth saving. 

Refer to Proposed Design in section 1 for parameters to be used in 

the project template. 
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10. Right click on Granular A component, select Delete Component 

from the pop-up menu. 

 

  

 

11. In the template display window, right click and select Delete 

Component from the pop-up menu. 

 

 

 

12. Left click and hold the left mouse button to draw a freehand line over 

the left side end condition components to delete. 
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13. Delete all the end condition components on the right side. 

 

 

 

14. Click File > Save. 

15. In the template display window, find and double click on the point    

L-TP-EP. On the Point Properties dialog, go to Constraints section. 

Type 2.00% in the Value field for the Slope constraint. 

 

 

 

16. Click Apply Then Close. 

17. Find and double click on the point R-TP-EP in the template display 

window. On the Point Properties dialog, type -2.00% in the Value field 

for the Slope constraint. 



 

 
InRoads Typical Example 3 – Version 1.0                                                                         Page 41 

 

 

18. Click Apply Then Close. 

19. Verify that the Slope constraint value is 2.0% for points L-TP-EP1 and 

R-TP-EP1.  

20. In the template display window, find and double click on the point    

L-TP-ES. On the Point Properties dialog, go to Constraints section. 

Type -2.50 in the Value field for the Horizontal constraint. 

 

 

  

21. Click Apply Then Close. 

22. Find and double click on the point R-TP-ES in the template display 

window. On the Point Properties dialog, type 2.50 in the Value field 

for the Horizontal constraint. 

 

 

 

23. Click Apply then Close. 
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24. Right click in the template display window, select Add New 

Component > Overlay/Stripping from the pop-up menu. 

 

 

 

25. Set the Current Component at the bottom of Create Template dialog 

with information input as shown below: 

 

 

 

26. Place the component along the top of existing left side granular 

shoulder. Start from point L-TP-EP, go through points L-TP-ES, L-TP-

BR, and end to point L-TA-ER. 

27. Right click on existing left shoulder component (L-Granular 

Shoulder) and select Delete Component from the pop-up menu to 

delete. 
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28. Double click on the point L-TA-ER in the template display window.  

 

 

 

29. Set the Point Properties as: 

 

 

 

30. Click Apply then Close. Right click in the template display window, 

select Add New Component > Overlay/Stripping from the pop-up 

menu. 

31. Set the Current Component at the bottom of Create Template dialog 

with information input as shown below: 
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32. Place the component along the top of existing right side granular 

shoulder. Start from point R-TP-EP, go through points R-TP-ES, R-

TP-BR, and end to point R-TA-ER. 

33. Right click on existing right shoulder component (R-Granular 

Shoulder) and select Delete Component from the pop-up menu to 

delete. 

34. Double click on the point R-TA-ER in the template display window 

and set the Point Properties as: 

 

 

 

35. Click Apply then Close.  
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36. Click File > Save. 

37. For asphalt top course depth, set Vertical constraint value to -0.04 for 

points L-AB1-EP, L-AB1-EP1, AB1-CL, R-AB1-EP1, and R-AB1-EP. 

38. For asphalt base course depth, set Vertical constraint value to -0.05 for 

points L-TA-EP, L-TA-IP1, TA-CL, R-TA-IP1, and R-TA-EP. 

39. Create a new Overlay/Stripping component Milling for existing 

pavement partial removal with information input as shown below: 

 

 

 

The component is to be placed at the bottom of asphalt base course. 

Start from point L-TA-EP, go through point TA-CL, and end to point 

R-TA-EP.  
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40. Create a new Overlay/Stripping component Asphalt Padding and set 

component properties as shown below: 

 

  

The component is to be placed at the bottom of asphalt base course. 

Start from point L-TA-EP, go through points L-TA-IP1, TA-CL, R-TA-

IP1, and end to point R-TA-EP. 

 

 

 

41. Select File > Save to save changes made to the template. 

42. Close the Create Template dialog. 

 

 

Urban New Construction Template 

 

Two templates are to be created for the urban new construction section of 

this example one with barrier curb and one with mountable curb.  

 

A) Urban Section with Barrier Curb Template 

 

The following typical and OPSD 600.010 Concrete Barrier Curb With 

Wide Gutter are used to create urban section with barrier curb template. 
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1. Select Modeler > Create Template to open the Create Template 

dialog.  

2. Select the template Example3 Resurfacing from the Template Library 

on the left side of the dialog. Right click on the template then click 

Copy on the pop-up menu. 

 

 

 

3. Right click on the folder Example3 then click Paste on the pop-up 

menu. 

 

 

 

4. Right click on the newly copied template and click Rename on the 

pop-up menu. Type in a new name Example3 Urban Barrier Curb. 
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5. Change the information in the Description field for template Example3 

Urban Barrier Curb.  Click File > Save 

 

 

 

6. Delete the Granular Shoulder components on both sides.  
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7. Delete component Milling and Asphalt Padding. 

 

 

 

 

 

8. Double click on MTO Library > Curb & Gutters from the Template 

Library on the left side of Create Template dialog. Left click and hold 

the left mouse button on the template Concrete Barrier - OPSD 

600.010. 

 

 

 

9. Drag the selected template to the right into the template display 

window. 
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While holding the left mouse button, right click on the right button. 

Select Mirror option from the pop-up menu. 

 

 

 

Two Curb & Gutter components appear. 

 

 

 

Select point R-TP-EP as the attach point. 

 

 

 

10. Double click on component L-OPSD 600.010. On the Component 

Properties dialog, toggle off the Close Shape option if it is on. 
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11. Double click on component R-OPSD 600.010. On the Component 

Properties dialog, toggle off the Close Shape option if it is on. 

12. Verify the dimensions of inserted curb and gutter components as per 

the OPSD provided. Update the components accordingly.   

13. Change the Vertical constraint value to -0.05 for both points L-TP-

GU2 and R-TP-GU2. 

 

L-TP-GU2 

 

 

R-TP-GU2 

 

 

14. Create a new shoulder component L-Shoulder. Right click in the 

template display window. Select Add New Component then 

Constrained from the pop-up menu. 
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Set the Current Component as shown below: 

 

 

 

15. Start from point L-TP-CU2 then click a point in the window to the left 

of the point L-TP-CU2. 

 

 

 

16. Move the cursor to the left of the newly created point L-, right click 

and toggle of the Closed Shape option from the pop-up menu. 

  

 

 

Left click to the left of point L- then right click and select Finish from 

the pop-up menu to complete the command. 
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17. Double click on point L-. The Point Properties dialog will appear. On 

the Point Properties dialog, select ES from the Name drop-down list. 

 

 

 

The Name field is populated with the selected name ES and the 

Surface Feature Style is changed to the style associated with the point 

name ES. 
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18. Rename the point name to L-TP-ES. Click Apply. Set the point 

constraints as: 

 

 

 

19. Click Apply and Close. 

20. Double click on point L-1. The Point Properties dialog will appear. On 

the Point Properties dialog, select BR from the Name drop-down list. 

Rename the point name to L-TP-BR. Click Apply. Set the point 

constraints as: 

 

 

 

21. Click Apply and Close. 

22. Similarly to the shoulder on the left side, create a new shoulder 

component R-Shoulder on the right side. 

23. Rename the edge of shoulder point to R-TP-ES and set the point 

constraints as: 
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24. Rename the rounding breakpoint to R-TP-BR and set the point 

constraints as: 

 

 

 

25. Click Apply and Close. 

26. Attach end conditions to the template. Double click on MTO Library 

> End Conditions from the Template Library on the left side of 

Create Template dialog. 

27. Left click and hold the left mouse button on the template Earth Cut V 

Ditch. 
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Drag the selected template to the right into the template display 

window.  

 

 

 

While holding the left mouse button, right click on the right button. 

Select Reflect option from the pop-up menu. 

 

 

 

Attach to point L-TP-BR. 

 

 

 

28. Select the template Earth Fill in the folder MTO Library > End 

Conditions from the Template Library on the left side of Create 

Template dialog. 

29. Left click and hold the left mouse button on the template Earth Fill. 

Drag it into the template display window and attach to point L-TP-BR. 
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30. Double click on component L-Earth Fill. On the Component 

Properties dialog, change the Priority to 3. 
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31. Click Apply and Close. 

32. Double click on component L-Earth Fill2. On the Component 

Properties dialog, change the Priority to 4. Click Apply and Close. 

33. Double click on point L-TS1. Toggle on Use Feature Name Override 

and type in L-TS. Click Apply and Close. 

 

 

 

34. Double click on point L-TC1. Toggle on Use Feature Name Override 

and type in L-TC. Click Apply and Close. 

35. Select the template Earth Cut V Ditch in the folder MTO Library > 

End Conditions from the Template Library on the left side of Create 

Template dialog. 

36. Left click and hold the left mouse button on the template Earth Cut V 

Ditch. Drag it into the template display window. While holding the 

left mouse button, right click on the right button. Toggle off the 

Reflect option from the pop-up menu. Attach the template to point R-

TP-BR. 

37. Select the template Earth Fill in the folder MTO Library > End 

Conditions from the Template Library on the left side of Create 

Template dialog. 

38. Left click and hold the left mouse button on the template Earth Fill. 

Drag it into the template display window and attach to point R-TP-BR. 

 

 

 

39. Find component R-Earth Fill and change the Priority to 3. 

40. Find component R-Earth Fill2 and change the Priority to 4. 

41. Toggle on Use Feature Name Override for both points R-TS1 and R-

TC1. Override R-TS1 with name R-TS and R-TC1 with name R-TC.  

42. Add paved shoulder components to the template. Double click on 

MTO Library > Asphalt Shoulder Types > Partially Paved – Type 

3 from the Template Library on the left side of Create Template 

dialog.  
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43. Left click and hold the left mouse button on the template Asphalt 

Shoulder Top Course. Drag it into the template display window. 

Toggle on the Reflect option and attach to point L-TP-CU2. 

 

 

 

44. Rename point L-TP-ES1 to L-TP-EPS and set Point Properties as 

shown below. 

 

 

 

45. Rename point L-PPS1-ES to L-PPS1-EPS and change the Surface 

Feature Style to Edge of Paved Shoulder. 

46. Change the Vertical constraint value to -0.08 for both points L-PPS1-

EPS and L-PPS1-EP. 
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47. Add paved shoulder components to the right shoulder. Attach the 

template Asphalt Shoulder Top Course to point R-TP-CU2 with the 

Reflect option toggled off.  

48. Rename point R-TP-ES1 to R-TP-EPS and set Point Properties as 

shown below. 

 

 

 

49. Rename point R-PPS1-ES to R-PPS1-EPS and change the Surface 

Feature Style to Edge of Paved Shoulder. 

50. Change the Vertical constraint value to -0.08 for both points R-PPS1-

EPS and R-PPS1-EP. 

51. Add granular components to the template. Double click on MTO 

Library > Granular Courses > Granular A & B from the Template 

Library on the left side of Create Template dialog. 
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52. Left click and hold the left mouse button on the template Inner & 

Outer Lanes. Drag it into the template display window. Toggle on the 

Mirror option and attach to point TP-CL. 

 

 

 

53. Move point L-TA-EP1 to point L-TA-EP and merge with point L-TA-

EP. Set point constraints for point L-TA-ER as: 

 

 

 

54. Rename point L-TB-AUX to L-TB-CU2 and set point constraints as: 

 

 

 

55. Set point constraints for point L-TB-GS as: 
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56. Rename point L-SG-AUX to L-SG-CU2 and set point constraints as: 

 

 

 

57.  Set point constraints for point L-SG-GR as: 

 

 

 

58. Add three points on components L-Granular A between points L-TA-

ER and L-TA-EP.  
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59. Insert the first point at existing points L-PPS1-EP and merge with 

point L-PPS1-EP. Insert the second point at L-CU2 and merge with L-

Cu2. Insert the third point at L-GU3 and merge with L-GU3. 

 

 

 

60. Set point constraints for point L-AB1-EP as: 

 

 

 

61. Set point constraints for point L-TA-EP as: 
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62. Repeat above process to modify the granular components on the right 

side. Rename point R-TB-AUX to R-TB-CU2 and set point constraints 

as: 

 

 

 

63. Rename point R-SG-AUX to R-SG-CU2 and set point constraints as: 

 

 

 

64. The point constraints for points R-TA-ER, R-TB-GS, R-SG-GR, R-

AB1-EP, and R-TA-EP are set as: 
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R-TA-ER 

 

 

R-TB-GS 

 

 

R-SG-GR 

 

 

R-AB1-EP 

 

 

R-TA-EP 
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65. Right click on the vertical line between components L-Granular A 

and R-Granular A then select Merge Components from the pop-up 

menu. Rename the merged component to Granular A. 

 

 

 

66. Right click on the vertical line between components L-Granular B 

and R-Granular B then select Merge Components from the pop-up 

menu. Rename the merged component to Granular B. 

 

 

 

67. Click File > Save. 

 

 

B) Urban Section with Mountable Curb Template 

 

The following typical and OPSD 600.030 Concrete Mountable Curb With 

Wide Gutter are used to create urban section with mountable curb 

template. 
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1. Select Modeler > Create Template to open the Create Template 

dialog.  

2. Select the template Example3 Urban Barrier Curb from the Template 

Library on the left side of the dialog. Right click on the template then 

click Copy on the pop-up menu. 

 

 

 

3. Right click on the folder Example3 then click Paste on the pop-up 

menu. 

 

 

 

4. Right click on the newly copied template and click Rename on the 

pop-up menu. 
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Rename it to Example3 Urban Mountable Curb. 

 

 

 

5. Change the Description for template Example3 Urban mountable 

Curb. 

 

 

 

6. Click File > Save. 

7. Delete the barrier curb components on both sides.  
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8. Double click on MTO Library > Curb & Gutters from the Template 

Library on the left side of Create Template dialog. 

9. Left click and hold the left mouse button on the template Concrete 

Mountable - OPSD 600.030. 

 

 

 

10. Drag the selected template to the right into the template display 

window. While holding the left mouse button, right click on the right 

button. Toggle on the Mirror option from the pop-up menu and attach 

the template to point R-TP-EP. 
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11. Double click on component L-OPSD 600.030. On the Component 

Properties dialog, toggle off the Close Shape option if it is on. 

 

 

 

12. Double click on component R-OPSD 600.030. On the Component 

Properties dialog, toggle off the Close Shape option if it is on. 

13. Verify the dimensions of inserted curb and gutter components as per 

the OPSD provided. Update the components accordingly. 

14. Change the Vertical constraint value to -0.05 for both points L-TP-

GU2 and R-TP-GU2. 

 

L-TP-GU2 

 

 

R-TP-GU2 
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15. Insert a point L-TP-CU1 between points L-TP-CU21 and L-TP-GU2. 

Set point constraints as: 

 

 

 

16. Move point L-TP-CU21 to point L-TP-CU2 and merge with point L-

TP-CU2. Set point constraints for point L-TP-CU2 as: 

 

 

 

17. Move point L-CU2 to point L-CU21 and merge with point L-CU2. Set 

point constraints for point L-CU2 as: 

 

 

 

18. Move point L-GU3 to point L-GU31 and merge with point L-GU3. Set 

point constraints for point L-GU3 as: 
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19. Set point constraints for point L-TP-EPS as: 

 

 

 

20. Set point constraints for point L-TP-ES as: 
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21. Insert a point R-TP-CU1 between points R-TP-CU21 and R-TP-GU2. 

Set point constraints as: 

 

 

 

22. Move point R-TP-CU2 to point R-TP-CU21 and merge with point R-

TP-CU2. Set point constraints for point R-TP-CU2 as: 

 

 

 

23. Move point R-CU2 to point R-CU21 and merge with point R-CU2. Set 

point constraints for point R-CU2 as: 
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24. Move point R-GU3 to point R-GU31 and merge with point R-GU3. Set 

point constraints for point R-GU3 as: 

 

 

 

 

 

 

25. Set point constraints for point R-TP-EPS as: 
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26. Set point constraints for point R-TP-ES as: 

 

 

 

27. Move point L-TA-ER to point L-PPS1-EPS and merge with point L-

PPS1-EPS.  

 

 

 

28. Set point constraints for point L-TB-GS as: 
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29. Set point constraints for point L-SG-GR as: 

 

 

 

 

 

30. Move point R-TA-ER to point R-PPS1-EPS and merge with point R-

PPS1-EPS.  
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31. Set point constraints for point R-TB-GS as: 

 

 

 

32. Set point constraints for point R-SG-GR as: 
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33. Click File > Save. Close the dialog. 
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7.0 Roadway Modeling 
 

7.1 Roadway Designer Overview 
 

InRoads Road Designer is a highly interactive command that allows user 

to perform a majority of the road design within the command itself. The 

main dialog has 3 views in standard mode and 4 views in superelevation 

or overlay mode. User will see the design results simultaneously in plan, 

profile, and the cross section at the current station. This command is also 

used to create new design surfaces that represent a new roadway or other 

type of surface. 

 

Before running Roadway Designer, you must have: 

• A horizontal and vertical alignment or a surface feature that defines 

the location of the roadway. 

• One or more existing surfaces. 

• One or more templates to define the proposed typical section(s). 

 

7.2 Creating Corridor 
 

1. Select Modeler > Roadway Designer. The Roadway Designer dialog 

appears with three view windows. 

2. Select Corridor > Corridor Management. 

3. On the Manage Corridors dialog, type Example3 in the Name field. 

4. Set the Surface Symbology to DTM_Proposed. 

5. Set the Type to Alignment. 

6. Select Ex3 for the Horizontal Alignment. 

7. Select Ex3 for the Vertical Alignment. 

8. Set PI Rounding Tangent to 0.000 

9. Toggle off the station Limits for applying to the entire alignment. 

10. Click Add to create the corridor. 
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11. Click Close to dismiss Manage Corridors dialog. If the Active Surface 

is not Ex3_OG, make sure it is loaded and select it from the drop-down 

list. 

 

 

 

12. Click File > Save As. The Save Roadway Design As dialog will 

appear. The location will be …\Example3\InRoads\Corridors as 

defined in the project default. 

13. For Save as type, select Roadway Design (*.ird). 

14. For File name, type Ex3. 

15. Click Save and close the Save As dialog. 
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16. Go to InRoads main menu, select File > Save As to update the project 

file with newly created Roadway Design file. 

 

7.3 Inserting Template Drops 
 

With an active corridor in place, the template drops can be added to the 

roadway design. 

 

1. On the Roadway Designer dialog, select Corridor > Template Drops. 

The Template Drops dialog will appear. 

2. In the Library Templates list window, select template Example3 > 

Example3 Resurfacing. 

3. Change the Interval to 25 and the Station should be 11+000.000.  

4. Click Add. The selected template is added to the Current Template 

Drops list. 

 

 

 

5. In the Library Templates list window, select template Example3 > 

Example3 Urban Barrier Curb. 

6. Change the Station to 11+100.000. Click Add. The selected template 

is added to the Current Template Drops list. 
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7. In the Library Templates list window, select template Example3 > 

Example3 Urban Mountable Curb. 

8. Change the Station to a 12+300.000. Click Add. The selected template 

is added to the Current Template Drops list. 

 

 

 

9. Disable template transition by clicking on the X in the Enable 

Transition column in the Current Template Drops list. 

 

 

 

The column will show blank after the transitions have been removed 

between the templates. 

 

 

 

10. Close the Template Drops dialog. Make sure the Active Surface is 

Ex3_OG. 
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7.4 Point Controls 
 

Point controls are used to modify the behavior of points in a template. 

Depending on the Mode selected, different control types can be applied to 

a point. Point Controls are used for pavement width transition. 

 

1. Select Corridor > Point Controls. The Point Controls dialog appears.   

2. On the Point Controls dialog, type Left Pavement Width Transition in 

the Control Description field. 

 

 

 

3. Select L-TP-EP from the Point drop-down list (or use the locate 

button). Set the Mode to Horizontal. Then select Alignment for 

Control Type, Ex3 for Horizontal Alignment.  
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4. Set Station Limits. Type a 12+400 in the Start field and a 12+500 in 

the Stop field.  

 

 

 

5. Set Horizontal Offsets. Type -7 in the Start field and -9 in the Stop 

field. Click Add. 

 

 

 

6. Change the Control Description to Right Pavement Width Transition. 

7. Select R-TP-EP from the Point drop-down list (or use the locate 

button). Make sure the Mode is Horizontal, the Control Type is 

Alignment, and the Horizontal Alignment is Ex3.  

8. Set Station Limits and Horizontal Offsets as: 

 

 

 

 

 

9. Click Add. 

 

 

 

10. Close the Point Controls dialog. Select File > Save to save the 

changes. 

11. Review sections in Cross Section Display.  
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Resurfacing: 

 

 

Urban Barrier Curb: 

 

 

Urban Mountable Curb: 
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7.5 End Condition Exceptions 
 

If the template end conditions do not provide a desired solution or a end 

condition transition is necessary, the End Condition Exceptions tool can be 

used to define end condition exceptions which are used to override the 

template’s end condition solution over a specified range.  

 

1. On the Roadway Designer dialog, select Corridor > End Condition 

Exceptions. 

2. Set both the Start and the Stop station to 11+125. 

3. Set Apply To option to Left Override. Click Add. 

 

 

 

4. Click on Edit button. On the Left Override dialog, delete the current 

end condition solution. 
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5. Double click on MTO Library > End Conditions from the Template 

Library on the left side of the dialog. 

6. Left click and hold the left mouse button on the template Earth Fill. 

Drag it into the template display window.  Toggle on the Reflect 

option and attach to the end condition attaching point. 

 

 

 

 

 

7. Click OK to close the editing dialog and return to End Condition 

Exceptions dialog. 

8. Change the Start station to a 12+275 and the Stop station to a 12+300. 

9. Set Apply To option to Right Transition. Click Add. 
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10. Click Edit. 

11. On the Edit Transition dialog, connect the points with thick green (+) 

symbols. Move mouse over the point and pause the mouse to display 

the point name. Connect both points R-TC1 and R-BC from the 

template with ditch component to the point R-TS on the template with 

the fill component. 

 

 

12. Click OK. The Edit Transition Middle point dialog appears to allow 

user to review the entire transition or add new components, edit points, 

merge points, add and delete point constraints. 
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13. Click OK to accept the solution or Cancel to return edit mode. 

14. Change the Start station to a 12+350 and the Stop station to a 12+400. 

15. Set Apply To option to Left Transition. Click Add. 

16. Click Edit. On the Edit Transition dialog, connect the points with 

thick green (+) symbols. 

 

 

 

17. Click OK to review the transition and click OK to accept it. 

18. Change the Start station to a 12+375 and the Stop station to a 12+400. 

19. Set Apply To option to Right Transition. Click Add. 
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20. Click Edit. On the Edit Transition dialog, connect the points with 

thick green (+) symbols. 

 

 

 

21. Click OK to review the transition and click OK to accept it. 

22. Change the Start station to a 12+400 and the Stop station to a 12+425. 

23. Set Apply To option to Right Transition. Click Add. 

24. Click Edit. On the Edit Transition dialog, connect the points with 

thick green (+) symbols. 

 

 

 

25. Click OK to review the transition and click OK to accept it. 
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26. Click Close to return to Roadway Designer dialog. Click Process All 

the sections and use the arrow button to review each section in the 

view. 

27. Select File > Save to save the changes. 

 

7.6 Creating Finished Surface 
 

1. On the Roadway Designer dialog, click Process All button under the 

cross-section view. 

2. Select Corridor > Create Surface.  

3. On the Create Surface dialog, verify that only corridor Example3 (if 

you have more than one corridors) is selected and all the options 

selected as shown below: 
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4. Click Apply. InRoads will process all the cross section in the selected 

corridor. When the process finish, click Close to dismiss the Create 

Surface dialog. 

5. Close Roadway Design. Save the changes when see following 

message. 

 

 

 

6. Go to InRoads Explorer. In the left pane, check the Surfaces folder. 

Surface Example3 is listed under Surfaces. 
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7. Right click on surface Example3 and select Properties from the pop-

up menu. 

8. Click on the Advanced tab on the Surface Properties dialog. Select 

DTM_Proposed from the Symbology drop-down list for both Cross 

Sections and Profiles. 

 

 

 

9. Click Apply > Close. 

10. Save design surface Example3. 

 

7.7 Creating Alternate Surfaces 
 

To create TA, TB and SG surfaces, specify the alternate surface name in 

the point properties and then check the Alternate Surface option when use 

Create Surface command. 

 

1. Select Modeler > Create Template.  

2. On the Create Template dialog, select template Example3 Urban 

Barrier Curb from Template Library. 

3. Double click on point L-TA-ER and type TA in the Alternate Surface 

field. Click Apply button. 
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4. Repeat above process for points L-PPS1-EP, L-TA-EP, L-TA-IP1, TA-

CL, R-TA-IP1, R-TA-EP, R-PPS1-EP, and R-TA-ER. 

5. Set Alternate Surface name to TB for points L-TB-GS, L-TB-GU2, L-

TB-EP, L-TB-IP1, TB-CL, R-TB-IP1, R-TB-EP, R-TB-CU2, and R-TB-

GS.  

6. Set Alternate Surface name to SG for points L-SG-GR, L-SG-CU2, L-

SG-EP, SG-CL, R-SG-EP, R-SG-CU2, and R-SG-GR.  

7. Save template library. 

8. Select template Example3 Urban Mountable Curb from Template 

Library. 

9. Set Alternate Surface name to TA for points L-PPS1-EPS, L-PPS1-EP, 

L-TA-EP, L-TA-IP1, TA-CL, R-TA-IP1, R-TA-EP, R-PPS1-EP, and R-

PPS1-EPS. 

10. Set Alternate Surface name to TB for points L-TB-GS, L-TB-CU2, L-

TB-EP, L-TB-IP1, TB-CL, R-TB-IP1, R-TB-EP, R-TB-CU2, and R-TB-

GS.  

11. Set Alternate Surface name to SG for points L-SG-GR, L-SG-CU2, L-

SG-EP, SG-CL, R-SG-EP, R-SG-CU2, and R-SG-GR. 

12. Save template library and close the Create Template dialog.  

13. Select Modeler > Roadway Designer. 

14. Select Corridor > Templates Drops.  

15. Select all the template drops in red and click on the Synchronize with 

Library button. Close the dialog. 

16. Process All the cross sections. 

17. Select Corridor > Create Surface. 

18. Select corridor Example3. 

19. Check the Create Alternate Surfaces option on the Create Surface 

dialog. 

 

 

 



 

 
InRoads Typical Example 3 – Version 1.0                                                                         Page 97 

20. Click Apply. Save Roadway Designer and close the dialog. 

21. Go to InRoads Explorer. In the left pane, check the Surfaces folder. 

Alternate surfaces are created under Surfaces. 

 

 

 

22. Right click on surface Example3-SG and select Properties from the 

pop-up menu.  

23. Click on the Advanced tab on the Surface Properties dialog. Select 

DTM_SG from the Symbology drop-down list for both Cross Sections 

and Profiles. 

 

  

24. Click Apply > Close. 

25. Repeat the process to set symbology DTM_TA for surface Example3-

TA. 
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26. Set symbology DTM_TB for surface Example3-TB. 

 

 

 

27. Save surfaces Example3, Example3-TA, Example3-TB, and 

Example3-SG. 

 

7.8 Updating Project File 
 

1. Go to InRoads main menu, select File > Save As. 

2. On the Save As dialog, verify the Save as type is Projects (*.rwk) and 

select Example3.rwk. 

3. Click the Options (…) button on the lower right corner of the Save As 

dialog box. The Project Options dialog box will appear. 

4. Click Surfaces tab, check Add for Example3 surface. 

 

 

 

5. Click OK button to close the Project Options dialog box. 

6. Click the Save button and confirm to replace existing project file.  
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8.0 Cross Sections 
 

8.1 Creating Cross Sections 
 

1. Load MTO_InRoads_Template_SS2.dwg from project 

folder...\Example3\\InRoads\Standards. 

2. Click MicroStation’s File > Save As command to save the drawing to 

project folder …\Example3\InRoads\Drawings with name 

Ex3_CrossSections. 

3. Set the Global Scale Factors to 0.1. 

4. Select Evaluation > Cross Section > Cross Sections. 

5. Click Preferences and load named preference MTO_Sheet(1:100). 

On the dialog of General leaf, select surface Ex3_OG and Example3 

from the Surfaces list.  

 

 

 

6. Click Source and verify that alignment Ex3 is show in the Alignment 

field. 

 

 



 

 
InRoads Typical Example 3 – Version 1.0                                                                         Page 100 

 

7. Click Controls > Limits. Verify the Station range.  

 

 

 

8. Click Critical Sections under Controls. Select options. 

 

  

 

9. Click Apply and follow the prompt from the status bar at the bottom 

of MicroStation window to provide an insert point in the drawing.  

10. Click Fit View icon from the view control bar at the top of the view 

window to see all the cross sections generated from Create Cross 

Section command.  
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11. Use the view control icons in the view control bar to change the view 

settings and exam the cross sections that have been created. 

 

Whole Sheet: 

  

Resurfacing: 

 

 

Urban Barrier Curb: 

 

 

Urban Mountable Curb: 

 

 

 

8.2 Updating Cross Sections 
 

1. Select Evaluation > Cross Section > Cross Sections. 

2. Click on the Update Cross Section folder on the left pane of Cross 

Sections dialog.  

3. Click on Crossing Features leaf. Toggle on the Display On option. 

4. Select surface Example3 from the Surface list. 

5. Turn on the Feature Filter Lock and select filter TP Surface Features, 

and then select all the features in the Feature list. 
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6. Click Apply.  Top surface features are displayed in the cross sections 

(shown as points). 

7. Turn off the Feature Filter Lock, select surface Example3 from the 

Surface list and click on the Style column in the Feature list to sort the 

features by style.  

 

 

 

 

 

8. Select features R-TC, L-TC, R-TS, and L-TS in the Feature list. Click 

Apply to display all the selected features in the cross sections (shown 

as points). 
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9. Select surface Example3 and sort the list again. Select features R-BC 

and L-BC from the list. Click Apply to display in the cross sections. 

 

 

 

10. Select surface Example3-SG from the Surface list. 

11. Select all the features in the Feature list (feature Exterior Boundary is 

greyed out and will not be selected). 
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12. Click Apply. All the subgrade surface features are displayed in the 

cross sections (shown as points). 

13. Close the dialog. 

 

8.3 Annotating Cross Sections 
 

Surface or surface crossing features (if loaded) can be annotated in cross 

sections. Verify that the Global Scale Factors is set to 0.1.  

 

OG surface 

 

1. Select Evaluation > Cross Section > Cross Sections. 

2. Click on the Annotate Cross Section folder on the left pane of Cross 

Sections dialog.  

3. Click on Preferences and load named preference MTO_OG (1:100).  

4. Click on General leaf and select Ex3_OG surface. 

5. Click on Points leaf and toggle on Include Points option. 
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6. Click Apply. The OG surface is annotated in cross sections. 

 

 

 

 

 

 

TP Surface.  

 

1. With the Cross Sections dialog open, click on Preferences and load 

named preference MTO_TP (1:100).  

2. Click on General leaf. Unselect surface Ex3_OG and select surface 

Example3. 

3. Click on Features leaf then click on Annotate. All the features added 

to the cross section set in section 8.2 are shown in the Feature list.  
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4. Click Apply. The top surface is annotated in cross sections. 

 

 

 

 

 

 

SG Surface.  

 

1. With the Cross Sections dialog open, click on Preferences and load 

named preference MTO_SG (1:100).  

2. Click on General leaf. Unselect surface Example3 and select surface 

Example3_SG. 

3. Click on Features leaf then click on Annotate. Select all the features 

from the Feature list. 
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4. Click Apply. The subgrade surface is annotated in cross sections. 

 

 

 

 

 

5. Close the Cross Sections dialog and save the drawing. 
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9.0 Volumes 
 

After creating cross section set, the End-Area Volumes can be used to 

perform the traditional end-area volume calculation to compute cut, fill, 

and net volumes. To compute the quantities of components, the 

components must be displayed in the cross section. 

  

InRoads calculates the exact end areas at each stations. The neat volumes 

area calculated between stations using the average end area method. The 

computed volumes can be adjusted for shrinkage or expansion.  

 

9.1 Calculating End-Area Volumes 
 

 

 

1. Verify that the cross section drawing created in previous section is 

loaded in MicroStation.  

2. Verify that the Global Scale Factors is set to 0.1. 

3. Select Evaluation > Cross Section > Cross Sections. 

4. Click on the End-Area Volumes folder on the left pane of Cross 

Sections dialog. 

5. Click on Preferences and load the named preference MTO.  

6. Click on Annotation. Check the default settings of the named 

Preference MTO.  Change the options as you need.  

 

Note:  The Compaction/Expansion factor and stripping depths used 

in this example are for demonstration only. For individual projects, 

refer to Geotechnical Report or the Regional Geotechnical Section’s 

recommendation. 



 

 
InRoads Typical Example 3 – Version 1.0                                                                         Page 109 

 

 

7. Click General. In the Surface list, make sure the existing surface 

Ex3_OG and the design surface Example3 are checked. With the 

preference MTO, the volume will be calculated for whole cross section 

set and the Create XML Report option is toggled on. 
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8. Click Unsuitable Materials by Station. For new construction, assume 

stripping will be across the entire cross section. Also assume the 

stripping depths are 0.15m in cuts and 0.30 in fills.  

9. Add the stripping section (11+100 to a 12+500) to the list with the 

Style set to Stripping, Cut Depth 0.15m and Fill Depth 0.30m.  

 

 

 

10. Click Classification. Use Cut/Fill Factor to account for any swell or 

shrinkage that may occur when remove/place material. Assume 15% 

increase for the computed earth fill quantity to compensate handing 

and compaction lose. Edit the Cut/Fill factors in the Materials List 

table. 
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11. Click Apply to calculate the volumes. InRoads will annotate the cross 

section set based on the selections on the Annotation leaf.  

 

 

 

12. With Create XML Report option toggled on, Bentley Civil Report 

Browser displayed. Select EndAreaVolume style sheet from the 

Evaluation folder in the left pane of the dialog to view the results. 
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13. Select Volumes style sheet and go to the end of the report. A summary 

table of total volumes of each material is generated by InRoads. There 

are 4 columns in the table. From left to right they are Material 

(component style) Name, Volume, Adjusted Volume, and if the 

material is included in the Mass Ordinate. 

 

 

 

14. Based on the template and the input during quantity calculation, the 

quantity of: 

 

a. Excavation  = Normal Cut 

  = 4420.90 m
3
 

b. Milling is the volume of the partial depth pavement removal (up 

to 50mm) calculated with the component Milling.  

 

Note:  Refer to Resurfacing Template in Section 6.2 for details. 
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Milling =12.69 m
3
 

 

c. To calculate the materials available for fill, the volume of 

pavement removed is to be subtracted from the excavated 

volume.  

 

Available Materials for Fill: 

  = Normal Cut (excavation) – Milling 

  = 4420.90 – 12.69 

  = 4408.21 

d. Asphalt Base Course 2 is the volume of asphalt padding.  

 

 

15. Save the drawing with a different name (Cross section with end-area 

quantities). 

 

9.2 Saving End-Area Volume Parameter File 
 

InRoads allows user to load and save project specific parameter files. 

Generating end-area volumes involves project specific parameters, the 

parameters used for End-Area Volumes calculation can be stored in an 

End-Area Volume parameter file (*.eav).  The Open, Save, and Save As 

commands can be accessed from the File menu on the Cross Section 

Dialog. 

 

1. On the Cross Section dialog, select File > Save As. 

2. On the End-Area Volume File dialog, click the Save in field to select a 

folder so save the file. By default the folder is the Reports folder as 

defined in project default. 

3. In the File Name field. Type in Example3. 

4. Click Save. A new .eav file Example3 is created. All the parameters 

entered under End-Area Volumes folder in previous section are now 

saved. 

 

Note:  Refer to Resurfacing Template in Section 6.2 for details. 
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10.0 Reports 
 

10.1   End-Area Volume Report 
 

The End-Area Volume Report is generated with End-Area Volumes 

command. Refer to Section 9.1 for details about end-area volume 

calculation and report generation. Once the report is generated by InRoads 

and the Bentley Civil Report Browser is displayed, a few style sheets from 

the Evaluation folder can be used to view End-Area Volume. 

 

 

 

10.2   Cross Section Reports 
 

Cross Section Report command is used to create station, offset, and 

elevation report for a specified cross section set. All surfaces, features, and 

components that you want in the report must be displayed in the cross 

section set. 

 

10.2.1 Top of Pavement (TP) Report 

 

The InRoads generated design surface can be used for Top of Pavement 

report. 

 

1. Open the saved cross section drawing (or you can generate a new set). 

2. Select Evaluation > Cross Section > Cross Section Report.  

3. On the Cross Section Report dialog, verify the Cross Section Set is 

Ex3. 

4. Select surface Example3 (design surface) from the Include Surfaces 

list. 
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5. Click Apply. 

6. In the Bentley Civil Report Browser, select Evaluation > 

CrossSectionStakingTable.xsl.  

 

 

 

7. Save the report then close the Bentley Civil Report Browser. 

 

10.2.2 TA and TB Reports 

 

1. Select Evaluation > Cross Section > Cross Sections. 
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2. Click on the Update Cross Section folder on the left pane of Cross 

Sections dialog. 

3. Click on Surfaces. Toggle on the Display On option. 

4. Select surface Example3-TA from the Surface list. Click Apply. 

5. Select surface Example3-TB from the Surface list. Click Apply. 

6. Toggle on the Display Off option to make sure TA and TB surfaces 

have been added to the cross section set. 

 

 

 

7. Close Cross Sections dialog. 

8. Select Evaluation > Cross Section > Cross Section Report. 

9. On the Cross Section Report dialog, verify the Cross Section Set is 

Ex3. 

10. Select surface Example3-TA from the Include Surfaces list. 
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11. Click Apply. 

12. In the Bentley Civil Report Browser, select Evaluation > 

CrossSectionGradeBookWide.xsl. 

 

 

 

13. Save the report then close the Bentley Civil Report Browser. 

14. On the Cross Section Report dialog, select surface Example3-TB from 

the Include Surfaces list. 

15. Click Apply. 

16. In the Bentley Civil Report Browser, select Evaluation > 

CrossSectionGradeBookWide.xsl. 

 

 

 

17. Save the report then close the Bentley Civil Report Browser. 

18. Close the Cross Section Report dialog. 
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10.2.3 Subgrade Report 

 

1. Repeat steps 1 to 7 in section 10.2.2 to add surface Example3-SG to 

the cross section set. 

2. Select Evaluation > Cross Section > Cross Section Report. 

3. On the Cross Section Report dialog, verify the Cross Section Set is 

Ex3. 

4. Select surface Example3-SG from the Include Surfaces list. 

5. Click Apply. 

6. In the Bentley Civil Report Browser, select Evaluation > 

CrossSectionGradeBookWide.xsl. 

 

 

 

7. Save the report then close the Bentley Civil Report Browser. 

8. Close the Cross Section Report dialog. 

 

 


