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Guideline for Importing Survey Data into 
Bentley Power InRoads v8i SS2 

 

I. REQUIREMENTS from the Geomatics/Survey Function: 

1. A CAD-only drawing in .DWG file format ver. 2013, (that can be created natively with 
Civil 3D versions 2013 through 2016, or by using “SAVEAS” with later versions) with 
existing survey features depicted in accordance with MTO AutoCAD symbol, line type 
and layer standards.  This drawing should contain only CAD drawing objects, and no 
Civil 3D objects.  

The recommended practice for creating this drawing is: 

a. Start with a Civil 3D (C3D) drawing that has been checked with the AUDIT 
command and cleaned with the PURGE and PURGESTYLES commands as 
may be needed, while retaining any styles that might be needed for future 
editing. 

b. Save drawing layer filters to an external file (.lft) using 
LAYERSAVEFILTERTREE, as filters are not carried over into exported 
drawings. 

c. Ensure that a surface style with visible triangles has been assigned to all 
surfaces. Contours are neither required nor recommended, but triangles serve 
as a visual record of the existing and edited final surface and may be needed by 
designers to check the InRoads surface. 

d. It’s recommended that surfaces have snapshots saved in the drawing, and that 
the surface border be extracted from the surface object as a 3D polyline. 

e. Use the EXPORTC3DDRAWING command to create the new CAD-only .DWG 
file;  

f. Reload the original drawing layer filters using the .lft file of part b. into the new 
CAD-only .DWG file with LAYERLOADFILTERTREE and save it. 

g. Note that the command LINETYPE3DPLINEON will render the 3D polylines that 
are converted from survey figures with their correct line type display in AutoCAD. 

Comment: 
 
A CAD-only file may also be created from Civil 3D using the AutoCAD EXPLODE 
command, however, it is not recommended because of the following disadvantages: 
• More than one EXPLODE command has to be executed. 
• Labels on objects like culverts in plan and profile views will be lost if the object to 

which the label is attached is exploded before the label. 
• Civil cogo point objects will be converted to a multitude of unnamed blocks [e.g, 

“*u1234”] without common names, making manipulation later more awkward. 
• Some users report the CAD-only file is less stable than one exported using 

EXPORTC3DDRAWING 
• Invisible C3D artifacts may remain in the drawing. 
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2. Project Road Alignment Geometries as an .XML file. 
 
An alignment-only XML may be exported using Civil 3D right-click menus on the surface 
branch of the Prospector tab, or by using File > Export > Export to LandXML. 
Alternatively, alignments may be found within the master .XML file that is created by the 
Autodesk Online Data Translation Service using the Geopak option. 
  

3. Project Original Ground (OG) and other surfaces as  

(a) Best: A Geopak format .tin file, generated using the online Autodesk®Civil 
Engineering Data Translator accessed from the Civil 3D 2016 Toolbox Tab> 
Productivity Pack 1  top branch.   This format is preferred because importing it into 
InRoads results in a full and exact triangulation identical to the original Civil 3D TIN, 
or  

(b)  An XML file exported via right-click on the surface from Civil 3D, or 

(c) A CAD layer with all the original surface 3D DTM TIN lines. This can be created 
after a Civil 3D surface style that contains visible triangles is assigned to the 
surface object. (See section 1.c., above.) 

To minimize the size of a drawing with this TIN layer,  
(i) EXPLODE the Civil 3D surface object to an AutoCAD block. 
(ii) EXPLODE the TIN block to Triangle Faces. 
(iii) Convert triangle faces to regions with AutoCAD command REGION. 
(iv) EXPLODE the regions to 3D lines. The result will contain a lot of 

redundant information because all triangle edges---except those on the 
outermost boundary of the surface---will be duplicated, since each 
triangle has a neighbour on all three sides. 

(v) From the [Planning] Workspace menu, use MAPCLEAN to delete 
duplicate lines. 

(vi) Resave. 
 
4.    Surveyed Points as an .XML or a comma-delimited ASCII text file (e.g, PENZD) 

(Again, points can be part of the Geopak XML export of the Autodesk Online Civil 
Engineering Data Translation service, or may be generated separately from a regular Civil 
3D menu item.) 

Using Autodesk’s online Civil Engineering Data Translator service: 

A. There is a standalone application that can be run without Civil 3D 2016 being active. 

B. [ Formerly, this service was accessed using the TOOLBOX tab > Civil 3D 2016 Productivity Pack 
1> Autodesk®Civil Engineering Data Translator branch, select Export Civil 3D to Bentley 
GEOPAK, but this is no longer the case.] 
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C. As of March 2019, the standalone Windows program accessed using WINDOWS > 
APPLICATIONS LIST > Autodesk > Autodesk Civil Engineering Data Translator: 

 

 

D. You will need to login to your personal Autodesk Account.  Select the source .DWG file you want 
to convert using the browser window, and select “Export Civil 3D to Bentley GEOPAK” 

E. The file will be uploaded to an Autodesk server, after which point you can select additional files to 
add to the translation queue, or  

F. You will be able to monitor the status of the conversion in the window: 

 

G. After Autodesk cloud processing is completed, a hyperlinked file name will appear in the “Result” 
field which you can click on to download to the subdirectory of your choice. 

H. A number of files will have been created by the online service, such as: 
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• <Surfacename>-001.tin is the Geopak format file recommended for importing a terrain 
model into InRoads 

• <DWG filename>.XML will contain cogo points and point groups, alignments, profiles, pipe 
networks, surface breaklines and surfaces 

• <filename>.xlsx  is a “Translation Report” table that lists the files that were created in the 
process and a summary of the file  

 
II. Importing Survey Data into Power InRoads v8i SS2: 
 

Review The Drawing File 

a) Open the CAD survey drawing file in Power InRoads. 

b) View drawing extents to confirm that there are no extraneous Civil 3D artifacts remaining 

the drawing.  

c) For example, artifacts in the drawing [e.g. “AECCDbFace”, “AeccLand100”] may remain 
at or near the drawing origin if the drawing was created using the AutoCAD EXPLODE 
method. 

a. Select artifact object(s).  

b. Edit > Unlock   [unlocks element for deleting; selection remains] 

 

c. Delete selection(s) with [DEL].  [object is deleted] 

d) Repeat (a) and (b) as needed until no artifacts remain. 

e) Inspect the drawing: 

a. Ground features will be at their surveyed elevations if the standard MTO Civil 3D 
template and files were used to generate them. 
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b. Survey boundary monuments, other drafted line work including culvert outlines, 
and text and profiles will  be at Z=0.  

f) Open the GEOPAK surface .tin file ,  

Having done so, you will see that a new surface appears in the surface tab, and that it is 
already FULLY TRIANGULATED.  There is no need to execute the “Triangulate” 
command in InRoads to create the TIN, and the Geopak model should be accurate with 
respect to the original.  There should be no need to perform any edits on this TIN, but if 
any edits are done, they can be saved to an InRoads .dtm file for further work. 

Next, PROCEED to step (l.), importing alignments. 

g) OR, if a Geopak TIN file is not available, open the .XML surface file: 

 

h) Triangulate the OG surface.  

i) Write these InRoads surface triangles to a drawing layer that’s different and different in 
colour from that of the triangles from the original survey that are already in the drawing 

to allow comparison:  

j) NOTE: These new InRoads XML surface triangles must be compared with those of the 
original survey already in the CAD file (SP-E-TIN-TRIANGLES). Testing has shown that 
when InRoads triangulates a surface imported from an XML file, it does so “from scratch” 
and independently of the original TIN.  It does not respect the triangulation that is 
contained within the XML file throughout the surface. This means that all triangles of 
the new TIN may not match all those of the original.  Accordingly, the new InRoads 
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surface triangulation must be edited by swapping triangles so that it matches the original 
TIN, and then saved.   

This may not be practical for large files, in which case it may be more efficient to use 
only the graphical 3D TIN lines that were created in Step 3(c) on page 1. 

k) IF IMPORTING A SURFACE USING CAD 3D LINES FROM A DTM TIN: 

a. Select all the 3D lines in the drawing (usually on layer SP-E-TIN-TRIANGLES) in 
the event that they have been already exploded from their parent triangles as in 
Step 3(c) on page 1. 

 

b. In the event that the triangles have not been reduced to lines, use the 
Microstation Drop command (equivalent to AutoCAD “EXPLODE”) to reduce the 
triangles to their constituent 3D lines, ensuring the “Line Strings/Shapes” setting 
is selected in the options box: 

 

c. Delete duplicate 3D lines using the Utilities > Design File Cleanup command 
using the “Line” and no “Match” settings. 
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d. Once selected, the duplicate lines can be deleted. 

e. Import the 3D lines using InRoads Import > Surface > from Level and select the 
level that contains the lines.    

f.  

g. Then triangulate this InRoads surface and review the triangles created by 
InRoads against the original. They should match exactly. 

 

l) Open the alignments using {Power InRoads} File > Open on an InRoads .alg file, or 
alternatively, use the LandXML translator feature (File> Translators> LandXML 
Translator). 

m) The alignments will appear in the Power InRoads geometry tab 
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n) Having imported the OG surface and alignments, existing road profiles may be 
generated using Power InRoads as needed. Graphic drainage data such as culverts and 
catchbasin depicted on the CAD survey profile can be copied to the InRoads profile, 
assuming that the horizontal and vertical scales on the original and new profile are 
identical. 

About InRoads Surfaces  

It is important to understand what is meant by an InRoads surface.   While most CAD and 
survey programs define a surface as simply a representation of connected ground 
elevations across an area, InRoads is different:  InRoads treats the TIN as just one 
component of a surface.  An InRoads surface database can also include all the surveyed 
existing features (break lines and others) that make up conventional topographic planimetry. 

Having 3-dimensional CAD features, OG surfaces and alignments may well be enough data 
on which to begin new design work, however, if cross sections are to be labelled with 
existing survey features, the features will have to be assigned their default MTO Standard 
InRoads feature styles. 

 

Assigning MTO Standard InRoads Features Styles to CAD features 

The general approach for this is to use the InRoads File > Import > Surface Advanced 
command to read all the CAD graphics items from their respective MTO standard layers and 
assign them their corresponding InRoads MTO feature style. 

 

Figure 1 - File Import > Surface Advanced dialogue 

A rule set contained within a supplied customized InRoads .XIN file contains the rules that 
are used to map the features from each CAD layer to each MTO InRoads feature style.   
Rule Sets can be copied, edited and saved by the user to accommodate any special needs.  
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Figure 2 - Rule Set dialogue with rules listed at the bottom 

 

Note that the default Rule Set depends on all features being on their respective MTO 
standard CAD layers.  Should there be odd, non-standard features in the survey drawing, 
they can be assigned their InRoads feature styles individually.  Do this by using the “Load 
From:” [Single Element] pull-down option in the Import Surface Advanced dialogue. 

Similarly, each rule in a Rule Set can be inspected or edited by double-clicking on the rule 
item in the Rule Set list.  There are three groups of settings (branches of the “Edit Import 
Rule”) that determine exactly how each rule works: General, Selection Criteria, and Process 
Settings.  The InRoads help file provides details on these settings. 

 

Figure 3 - Edit Rule dialogue box 

All features that have been imported into the InRoads surface can be reviewed using the 
InRoads command sequence, Surface > Feature > Feature Properties to yield a list of 
items and the MTO standard style that has been assigned to each. 
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Figure 4 - Command sequence for viewing features 

 

Figure 5 - List of features in a surface 

Having imported survey features in this manner provides the InRoads user the ability to label 
them on cross sections and profiles. 
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